summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Lin2016-09-03 13:55:35 -0500
committerJesse Lin2016-09-03 14:09:50 -0500
commit3a84e5f5eb51146531eababb1692e428ca7478d6 (patch)
tree2fce0c47fbc6d0ead96a8b5068ac53a84a07bd0f
downloadaur-3a84e5f5eb51146531eababb1692e428ca7478d6.tar.gz
dbus with x11 autolaunch compiled in
-rw-r--r--.SRCINFO32
-rw-r--r--0001-Drop-Install-sections-from-user-services.patch44
-rw-r--r--PKGBUILD66
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8962aad0fff0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = dbus
+ pkgdesc = Freedesktop.org message bus system
+ pkgver = 1.10.10
+ pkgrel = 3
+ url = https://wiki.freedesktop.org/www/Software/dbus/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = systemd
+ makedepends = xmlto
+ makedepends = docbook-xsl
+ makedepends = python
+ makedepends = yelp-tools
+ makedepends = doxygen
+ depends = libsystemd
+ depends = expat
+ depends = dbus-docs
+ source = https://dbus.freedesktop.org/releases/dbus/dbus-1.10.10.tar.gz
+ source = https://dbus.freedesktop.org/releases/dbus/dbus-1.10.10.tar.gz.asc
+ source = 0001-Drop-Install-sections-from-user-services.patch
+ validpgpkeys = DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90
+ validpgpkeys = 3C8672A0F49637FE064AC30F52A43A1E4B77B059
+ sha256sums = 9d8f1d069ab4d1a0255d7b400ea3bcef4430c42e729b1012abb2890e3f739a43
+ sha256sums = SKIP
+ sha256sums = 48135124680bd9ea2d7d2bd2a9f457608d97bd9aa7cb4f4396e26a1c2c91af3e
+
+pkgname = dbus-x11
+ provides = libdbus
+ conflicts = libdbus
+ replaces = libdbus
+
diff --git a/0001-Drop-Install-sections-from-user-services.patch b/0001-Drop-Install-sections-from-user-services.patch
new file mode 100644
index 000000000000..e62daccaf279
--- /dev/null
+++ b/0001-Drop-Install-sections-from-user-services.patch
@@ -0,0 +1,44 @@
+From 09cb6d7b467f6d1c6685ee9ccc171f4dddbe1f42 Mon Sep 17 00:00:00 2001
+From: Simon McVittie <simon.mcvittie@collabora.co.uk>
+Date: Sat, 7 Nov 2015 13:03:47 +0100
+Subject: [PATCH] Drop [Install] sections from user services
+
+We install the symlink to enable dbus.socket statically, so it doesn't
+make much sense to invoke `systemctl enable` on it; and
+dbus.service should normally be started by socket activation
+(or possibly an explicit dependency) rather than manually.
+
+Bug: https://bugs.freedesktop.org/show_bug.cgi?id=92402
+Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
+Reviewed-by: Lennart Poettering
+---
+ bus/systemd-user/dbus.service.in | 3 ---
+ bus/systemd-user/dbus.socket.in | 4 ----
+ 2 files changed, 7 deletions(-)
+
+diff --git a/bus/systemd-user/dbus.service.in b/bus/systemd-user/dbus.service.in
+index b41f522b8af8c174..4355d72844079cc5 100644
+--- a/bus/systemd-user/dbus.service.in
++++ b/bus/systemd-user/dbus.service.in
+@@ -6,6 +6,3 @@ Requires=dbus.socket
+ [Service]
+ ExecStart=@EXPANDED_BINDIR@/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation
+ ExecReload=@EXPANDED_BINDIR@/dbus-send --print-reply --session --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig
+-
+-[Install]
+-Also=dbus.socket
+diff --git a/bus/systemd-user/dbus.socket.in b/bus/systemd-user/dbus.socket.in
+index 4793d1d4ff1dc13e..304ac4034208f811 100644
+--- a/bus/systemd-user/dbus.socket.in
++++ b/bus/systemd-user/dbus.socket.in
+@@ -4,7 +4,3 @@ Description=D-Bus User Message Bus Socket
+ [Socket]
+ ListenStream=%t/bus
+ ExecStartPost=-@SYSTEMCTL@ --user set-environment DBUS_SESSION_BUS_ADDRESS=unix:path=%t/bus
+-
+-[Install]
+-WantedBy=sockets.target
+-Also=dbus.service
+--
+2.9.3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b72f04887467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# $Id: PKGBUILD 274760 2016-08-28 01:55:59Z heftig $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Link Dupont <link@subpop.net>
+
+pkgbase=dbus
+pkgname=dbus-x11
+pkgver=1.10.10
+pkgrel=3
+pkgdesc="Freedesktop.org message bus system"
+url="https://wiki.freedesktop.org/www/Software/dbus/"
+arch=(i686 x86_64)
+license=(GPL custom)
+depends=(libsystemd expat dbus-docs)
+makedepends=(systemd xmlto docbook-xsl python yelp-tools doxygen)
+source=(https://dbus.freedesktop.org/releases/$pkgbase/$pkgbase-$pkgver.tar.gz{,.asc}
+ 0001-Drop-Install-sections-from-user-services.patch)
+sha256sums=('9d8f1d069ab4d1a0255d7b400ea3bcef4430c42e729b1012abb2890e3f739a43'
+ 'SKIP'
+ '48135124680bd9ea2d7d2bd2a9f457608d97bd9aa7cb4f4396e26a1c2c91af3e')
+validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
+ '3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
+
+prepare() {
+ cd $pkgbase-$pkgver
+ patch -Np1 -i ../0001-Drop-Install-sections-from-user-services.patch
+ autoreconf -fvi
+}
+
+build() {
+ cd $pkgbase-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=dbus \
+ --with-system-pid-file=/run/dbus/pid \
+ --with-system-socket=/run/dbus/system_bus_socket \
+ --with-console-auth-dir=/run/console/ \
+ --enable-inotify --disable-static \
+ --disable-verbose-mode --disable-asserts \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --enable-systemd --enable-user-session \
+ --enable-x11-autolaunch
+ make
+}
+
+check() {
+ cd $pkgbase-$pkgver
+ make check
+}
+
+package() {
+ provides=(libdbus)
+ conflicts=(libdbus)
+ replaces=(libdbus)
+
+ cd $pkgbase-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir/var/run"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgbase/COPYING"
+
+ # Split docs
+ rm -r "$pkgdir/usr/share/doc"
+}