summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsuthernfriend2019-04-24 21:46:53 +0300
committersuthernfriend2019-04-24 21:49:14 +0300
commit69025cb3c9c8e3b140a678f1e14ae86e38ee109c (patch)
tree44c19d63ed77683b52589e837b4a6103474233c5
parentc2cc7608cb3638492530a42054f78bf051108702 (diff)
downloadaur-69025cb3c9c8e3b140a678f1e14ae86e38ee109c.tar.gz
Updated version to 1.3.163 and cleaned up package
WARNING: In case you're updating from 1.3.162 or smaller: The data directory has moved from /opt/dcc to /var/lib/dcc if you disagree with this change set the '_dstdir' variable argument in the PKGBUILD to "/opt/${pkgname}"
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD66
4 files changed, 47 insertions, 43 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index d5ca1e503a3a..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,14 +0,0 @@
-pkgbase = dcc
- pkgdesc = Distributed Checksum Clearinghouse spam tool
- pkgver = 1.3.158
- pkgrel = 1
- url = http://www.rhyolite.com/anti-spam/dcc/
- arch = i686
- arch = x86_64
- license = custom
- depends = sh
- source = http://www.rhyolite.com/anti-spam/dcc/source/old/dcc-1.3.158.tar.Z
- source = http://www.rhyolite.com/dcc/LICENSE
-
-pkgname = dcc
-
diff --git a/.SRCINFO b/.SRCINFO
index 5a400b8d2df8..e738629053b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = dcc
pkgdesc = Distributed Checksum Clearinghouse spam tool
- pkgver = 1.3.162
+ pkgver = 1.3.163
pkgrel = 1
- url = http://www.rhyolite.com/anti-spam/dcc/
- arch = i686
+ url = http://www.rhyolite.com/anti-spam/dcc
arch = x86_64
license = custom
depends = sh
- source = http://www.rhyolite.com/anti-spam/dcc/source/old/dcc-1.3.162.tar.Z
- sha256sums = f98413df06d1c25a56cafc016adf9e3348ccce6bc575ea5b7d12556b8e83bc91
+ source = https://www.dcc-servers.net/dcc/source/old/dcc-1.3.163.tar.Z
+ sha256sums = 195195b79ee15253c4caf48d4ca3bf41b16c66a8cb9a13984a1dc4741d7f6735
pkgname = dcc
diff --git a/.gitignore b/.gitignore
index 6ff5772472c0..7a0a0cac9f9f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
src/
pkg/
*.un~
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index bc69814600b7..f2d8617ff065 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,57 @@
-# Maintainer: John Lane <archlinux at jelmail dot com>
+# Maintainer: Jan Peter Koenig <public@janpeterkoenig.com>
+# Contributor: John Lane <archlinux at jelmail dot com>
# Contributor: Nathan Owe <ndowens.aur at gmail dot com>
pkgname=dcc
-pkgver=1.3.162
+pkgver=1.3.163
pkgrel=1
pkgdesc="Distributed Checksum Clearinghouse spam tool"
-url="http://www.rhyolite.com/anti-spam/dcc/"
-arch=('i686' 'x86_64')
+url="http://www.rhyolite.com/anti-spam/dcc"
+arch=('x86_64')
license=('custom')
depends=('sh')
-source=(http://www.rhyolite.com/anti-spam/dcc/source/old/$pkgname-$pkgver.tar.Z)
-sha256sums=('f98413df06d1c25a56cafc016adf9e3348ccce6bc575ea5b7d12556b8e83bc91')
+
+source=(
+ "https://www.dcc-servers.net/dcc/source/old/${pkgname}-${pkgver}.tar.Z"
+)
+
+sha256sums=(
+ '195195b79ee15253c4caf48d4ca3bf41b16c66a8cb9a13984a1dc4741d7f6735'
+)
+
+_dstdir="/var/lib/${pkgname}"
build() {
- cd $srcdir/$pkgname-$pkgver
- CPPFLAGS="$CPPFLAGS -O2" # https://bbs.archlinux.org/viewtopic.php?id=182812
- ./configure --with-installroot=${pkgdir} \
- --mandir=/usr/share/man --homedir=/opt/dcc \
- --bindir=/usr/bin --libexecdir=/usr/lib/dcc
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Following fix is no longer needed
+ # CPPFLAGS="$CPPFLAGS -O2" # https://bbs.archlinux.org/viewtopic.php?id=182812
+
+ ./configure \
+ --with-installroot="${pkgdir}" \
+ --mandir="/usr/share/man" \
+ --homedir="${_dstdir}" \
+ --bindir="/usr/bin" \
+ --libexecdir="/usr/lib/${pkgname}"
+
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- MAKEFLAGS="$MAKEFLAGS -j1" # AUR comment zmeYski 2014-10-14 17:57
- make DESTDIR=${pkgdir}/ install
- install -d $pkgdir/usr/share/licenses/$pkgname
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
-
- #Fix file permissions
- find $pkgdir/ -group bin -exec chgrp root {} \;
- find $pkgdir/ -user bin -exec chown root {} \;
- find $pkgdir/opt/dcc -type f -exec chmod 644 {} \;
- chmod 755 $pkgdir/opt/dcc/log
-
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # AUR comment zmeYski 2014-10-14 17:57
+ MAKEFLAGS="$MAKEFLAGS -j1"
+
+ make DESTDIR="${pkgdir}/" install
+
+ # License
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Fix file and dir permissions
+ chown -R root:root "${pkgdir}/"
+ # Fix libraries not being stripped
+ find "${pkgdir}/" -exec file {} \; | grep -i elf|grep "not stripped"|awk -F: '{ print $1 }'|xargs strip
}