summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Angel Useche Castro2017-07-29 18:26:01 -0400
committerMiguel Angel Useche Castro2017-07-29 18:26:01 -0400
commit153ce020ed9f924dd02b4893d67b4aa08cc97bd5 (patch)
treecf9756b46b4f76199a633513941d967ff4ccf5b0
parent1f6d410072fdae052fc42d832ad9089311d1c54b (diff)
downloadaur-153ce020ed9f924dd02b4893d67b4aa08cc97bd5.tar.gz
Updating to 3.6.2 with bundled chals
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD45
2 files changed, 11 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99eccc64086f..b82a595ecf8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dcmtk
- pkgdesc = a collection of libraries and applications implementing large parts the DICOM standard
- pkgver = 3.6.0
- pkgrel = 6
+ pkgdesc = A collection of libraries and applications implementing large parts the DICOM standard
+ pkgver = 3.6.2
+ pkgrel = 0
url = http://dicom.offis.de/dcmtk
arch = i686
arch = x86_64
@@ -15,12 +15,9 @@ pkgbase = dcmtk
depends = openssl
depends = charls
depends = libssh
- noextract = dcmtk-3.6.0-18.fc22.src.rpm
options = !buildflags
- source = ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/dcmtk360/dcmtk-3.6.0.tar.gz
- source = http://kojipkgs.fedoraproject.org/packages/dcmtk/3.6.0/18.fc22/src/dcmtk-3.6.0-18.fc22.src.rpm
- sha512sums = 2a9d866bafcaea72d889d24b51ff2341ee39c717aacf9ae5825c8588cd5cb01c3e341b6173abce751f6cb32c45be8888e81ccb08967cae2cca7fdcb2b61be53c
- sha512sums = aa6ec7968f27c9b4dfde46e14ba429b3f82ce595594676667c8b70d727e3b0881485cd4557c7bc3a4acdb31a6f49e33588303060d335025b1053d0b61d848b60
+ source = ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/dcmtk362/dcmtk-3.6.2.tar.gz
+ sha512sums = a3190287b068ae17984909dd9e8d920ddea3b590fc3888c42fc33fca4a3cdcf7dcc9bd64d994620303eef7c7ab7b4184ac21ebd1167ae2c17e4a88f641d7ef94
pkgname = dcmtk
diff --git a/PKGBUILD b/PKGBUILD
index c0d283640f7b..d7677eb35b33 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,58 +5,25 @@
# Most of this PKGBUILD + patches were taken from Fedora's dcmtk spec file, so thanks to the Fedora packagers for making this package work!
pkgname=dcmtk
-pkgver=3.6.0
+pkgver=3.6.2
-# Fedora release (from Koji)
-_fedora_rel=18.fc22
-# Newer Fedora releases in the future can be found at http://koji.fedoraproject.org/
-
-pkgrel=6
-pkgdesc="a collection of libraries and applications implementing large parts the DICOM standard"
+pkgrel=0
+pkgdesc="A collection of libraries and applications implementing large parts the DICOM standard"
arch=('i686' 'x86_64')
url="http://dicom.offis.de/dcmtk"
license=('other')
depends=('zlib' 'libpng' 'libtiff' 'libxml2' 'openssl' 'charls' 'libssh')
makedepends=('cmake' 'make')
-source=("ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/dcmtk360/${pkgname}-${pkgver}.tar.gz"
- "http://kojipkgs.fedoraproject.org/packages/dcmtk/${pkgver}/${_fedora_rel}/src/${pkgname}-${pkgver}-${_fedora_rel}.src.rpm")
-noextract=("${pkgname}-${pkgver}-${_fedora_rel}.src.rpm")
-sha512sums=('2a9d866bafcaea72d889d24b51ff2341ee39c717aacf9ae5825c8588cd5cb01c3e341b6173abce751f6cb32c45be8888e81ccb08967cae2cca7fdcb2b61be53c'
- 'aa6ec7968f27c9b4dfde46e14ba429b3f82ce595594676667c8b70d727e3b0881485cd4557c7bc3a4acdb31a6f49e33588303060d335025b1053d0b61d848b60')
+source=("ftp://dicom.offis.de/pub/dicom/offis/software/dcmtk/dcmtk362/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('a3190287b068ae17984909dd9e8d920ddea3b590fc3888c42fc33fca4a3cdcf7dcc9bd64d994620303eef7c7ab7b4184ac21ebd1167ae2c17e4a88f641d7ef94')
#Currently it's not building otherwise
options=(!buildflags)
build() {
cd "${srcdir}"
- # Extract RPM into another directory
- if [ ! -d fedora ]; then
- mkdir fedora
- fi
-
- pushd fedora
- bsdtar -xf "../${pkgname}-${pkgver}-${_fedora_rel}.src.rpm"
- popd
-
- sum_original=`sha512sum "${srcdir}/fedora/${pkgname}-${pkgver}.tar.gz" | awk '{print $1}'`
- sum_fedora=`sha512sum "${srcdir}/${pkgname}-${pkgver}.tar.gz" | awk '{print $1}'`
-
- # Verify the authenticity of both the Fedora source and the upstream source
- if [[ $sum_fedora != $sum_original ]]; then
- error "sha512 sums of Fedora's source and upstream source do not match!"
- exit
- fi
-
cd "${pkgname}-${pkgver}"
- # Apply Fedora patches (fixes build)
- for i in $(cat "${srcdir}/fedora/${pkgname}.spec" | grep "Patch[0-9]*:" | awk '{print $2}'); do
- patch -p1 -i "${srcdir}/fedora/${i}"
- done
-
- # Remove bundled charls
- rm -rf dcmjpls/libcharls/
-
# Fix linker flags
export LDFLAGS="-lssh -lz ${LDFLAGS}"
@@ -92,4 +59,4 @@ package() {
# Install ld config file
install -dm755 "${pkgdir}/etc/ld.so.conf.d/"
echo "/usr/lib/" > "${pkgdir}/etc/ld.so.conf.d/${pkgname}.conf"
-} \ No newline at end of file
+}