summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Angel Useche Castro2018-03-13 08:47:30 -0400
committerMiguel Angel Useche Castro2018-03-13 08:47:30 -0400
commitbdc8ed49b98b0830122f9c9ee4e3e502f6856204 (patch)
treedba0956570982aa1af668c0f7d3ada9b408dc2c9
parent9d843efac0f8d9f2f7dbf5ae8ef0247ca77ef740 (diff)
downloadaur-bdc8ed49b98b0830122f9c9ee4e3e502f6856204.tar.gz
Adding library path to cmake
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e0888982b76..3395bb558ac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dcmtk
pkgdesc = A collection of libraries and applications implementing large parts the DICOM standard
pkgver = 3.6.3
- pkgrel = 1
+ pkgrel = 2
url = http://dicom.offis.de/dcmtk
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5e3ed17da2a3..547a6305a6ea 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dcmtk
pkgver=3.6.3
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of libraries and applications implementing large parts the DICOM standard"
arch=('i686' 'x86_64')
url="http://dicom.offis.de/dcmtk"
@@ -28,6 +28,8 @@ build() {
cmake . \
-DCMAKE_BUILD_TYPE:STRING="Release" \
-DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_INSTALL_LIBDIR:PATH=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR:PATH=lib \
-DDCMTK_WITH_OPENSSL:BOOL=ON \
-DDCMTK_WITH_PNG:BOOL=ON \
-DDCMTK_WITH_PRIVATE_TAGS:BOOL=ON \
@@ -51,8 +53,8 @@ package() {
find "${pkgdir}" -type f -empty -exec rm -v {} \;
install -dm755 "${pkgdir}/usr/lib/"
-
+
# Install ld config file
install -dm755 "${pkgdir}/etc/ld.so.conf.d/"
echo "/usr/lib/" > "${pkgdir}/etc/ld.so.conf.d/${pkgname}.conf"
-} \ No newline at end of file
+}