summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-12-06 21:51:18 +0100
committerml2020-12-06 21:58:56 +0100
commit72cae987cdddfa022a4672992b580c3b54bd2aa8 (patch)
tree5648f702727ca30c797fa8f0e1f505092b37b5cc
downloadaur-72cae987cdddfa022a4672992b580c3b54bd2aa8.tar.gz
updpkg: dcnnt 0.3.6-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..607d248b245a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dcnnt
+ pkgdesc = Yet another tool to connect Android phone with desktop similar to KDE Connect
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/cyanomiko/dcnnt-py
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-pycryptodome
+ source = https://github.com/cyanomiko/dcnnt-py/archive/0.3.6/dcnnt-py-0.3.6.tar.gz
+ sha256sums = 9358aff1c0bdb227304923bdd7e539fda6ba5dea9e83fd772b1a23187ccf5271
+
+pkgname = dcnnt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91224e5de829
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+**/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d86d6d3c4bed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ml <>
+pkgname=dcnnt
+pkgver=0.3.6
+pkgrel=1
+pkgdesc='Yet another tool to connect Android phone with desktop similar to KDE Connect'
+arch=('any')
+url='https://github.com/cyanomiko/dcnnt-py'
+license=('MIT')
+depends=('python-pycryptodome')
+makedepends=('python-setuptools')
+source=("$url/archive/$pkgver/$pkgname-py-$pkgver.tar.gz")
+sha256sums=('9358aff1c0bdb227304923bdd7e539fda6ba5dea9e83fd772b1a23187ccf5271')
+
+build() {
+ cd "$pkgname-py-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-py-$pkgver"
+ install -dm755 "$pkgdir/usr/share/doc/$pkgname"
+ cp -a README.md doc/ -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}