summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-10-09 21:45:32 -0700
committerAndy Weidenbaum2017-10-09 21:45:32 -0700
commitf35ceb32b91a5dc48322b807fc4292e10e19c12b (patch)
treee3365c29a207e2caf8d91873c8532437669a4d14
downloadaur-f35ceb32b91a5dc48322b807fc4292e10e19c12b.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD54
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e9b05a9c6b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Oct 10 04:45:13 UTC 2017
+pkgbase = dcrdata-git
+ pkgdesc = Decred block explorer
+ pkgver = 20171009
+ pkgrel = 1
+ url = https://github.com/dcrdata/dcrdata
+ arch = armv6h
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ groups = decred
+ license = ISC
+ makedepends = dep
+ makedepends = git
+ makedepends = go
+ provides = dcrdata
+ conflicts = dcrdata
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/dcrdata/dcrdata
+ sha256sums = SKIP
+
+pkgname = dcrdata-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4abff3a5b96a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=dcrdata-git
+pkgver=20171009
+pkgrel=1
+pkgdesc="Decred block explorer"
+arch=('armv6h' 'armv7h' 'i686' 'x86_64')
+makedepends=('dep' 'git' 'go')
+groups=('decred')
+url="https://github.com/dcrdata/dcrdata"
+license=('ISC')
+options=('!strip' '!emptydirs')
+source=(git+https://github.com/dcrdata/dcrdata)
+sha256sums=('SKIP')
+provides=('dcrdata')
+conflicts=('dcrdata')
+
+pkgver() {
+ date +%Y%m%d
+}
+
+prepare() {
+ export GOPATH="$srcdir"
+ git clone "$srcdir/dcrdata" "$GOPATH/src/github.com/dcrdata/dcrdata"
+}
+
+build() {
+ export GOPATH="$srcdir"
+
+ msg2 'Building dcrdata and dependencies...'
+ cd "$GOPATH/src/github.com/dcrdata/dcrdata"
+ dep ensure
+ go install . ./cmd/...
+}
+
+package() {
+ msg2 'Installing license...'
+ install -Dm 644 "$srcdir/src/github.com/dcrdata/dcrdata/LICENSE" \
+ -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+
+ msg2 'Installing docs...'
+ for _doc in CODE_OF_CONDUCT \
+ CONTRIBUTING.md \
+ README.md \
+ sample-dcrdata.conf \
+ sample-nginx.conf \
+ sample-rate_limiting.html; do
+ install -Dm 644 "$srcdir/src/github.com/dcrdata/${pkgname%-git}/$_doc" \
+ -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+ done
+
+ msg2 'Installing...'
+ install -Dm 755 "$srcdir/bin"/* -t "$pkgdir/usr/bin"
+}