summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgt2015-06-17 10:16:15 +0530
committergt2015-06-17 10:16:15 +0530
commita0b176b32eb1c6155e3d774bdbba114805770fac (patch)
tree139c465c5eb92fa2e2c06bd697d67528fb730c70
downloadaur-a0b176b32eb1c6155e3d774bdbba114805770fac.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD52
-rw-r--r--service11
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6239514df684
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dcron
+ pkgdesc = dillon's lightweight cron daemon
+ pkgver = 4.5
+ pkgrel = 5
+ url = http://www.jimpryor.net/linux/dcron.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = bash
+ optdepends = msmtp-mta: sending cron job output via email
+ provides = cron
+ conflicts = cron
+ backup = var/spool/cron/root
+ backup = etc/conf.d/crond
+ source = http://www.jimpryor.net/linux/releases/dcron-4.5.tar.gz
+ source = service
+ md5sums = 078833f3281f96944fc30392b1888326
+ md5sums = 2eefc422db24bf2ac38e3a16292ccdc4
+
+pkgname = dcron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5d1fca6303e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: notfoss <AT> gmx.com
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: Paul Mattal <paul.archlinux.org>
+
+pkgname="dcron"
+pkgver="4.5"
+pkgrel="5"
+pkgdesc="dillon's lightweight cron daemon"
+arch=("i686" "x86_64")
+license=("GPL")
+url="http://www.jimpryor.net/linux/dcron.html"
+backup=("var/spool/cron/root" "etc/conf.d/crond")
+depends=("bash")
+optdepends=("msmtp-mta: sending cron job output via email")
+provides=("cron")
+conflicts=("cron")
+source=("http://www.jimpryor.net/linux/releases/${pkgname}-${pkgver}.tar.gz"
+ "service")
+md5sums=("078833f3281f96944fc30392b1888326"
+ "2eefc422db24bf2ac38e3a16292ccdc4")
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+
+ # fix paths to point to /usr/bin
+ sed -i 's=/usr/sbin/sendmail=/usr/bin/sendmail=g' defs.h
+ sed -i 's=/usr/sbin/run-cron=/usr/bin/run-cron=g' extra/root.crontab
+
+ # by default, any member of group "users" can edit their own crontab
+ make \
+ PREFIX=/usr \
+ SBINDIR=/usr/bin \
+ CRONTAB_GROUP=users \
+ CRONTABS=/var/spool/cron \
+ CRONSTAMPS=/var/spool/cronstamps
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # install standard configuration and scripts
+ install -d -m755 "$pkgdir"/etc/cron.{hourly,daily,weekly,monthly}
+
+ install -D -m755 extra/run-cron "$pkgdir"/usr/bin/run-cron
+ install -D -m0600 extra/root.crontab "$pkgdir"/var/spool/cron/root
+ install -D -m0644 extra/crond.conf "$pkgdir"/etc/conf.d/crond
+ install -D -m644 extra/crontab.vim "$pkgdir"/usr/share/vim/vimfiles/ftplugin/crontab.vim
+ sed -i -e 's=/var/spool/cron/cronstamps=/var/spool/cronstamps=' extra/prune-cronstamps
+ install -D -m755 extra/prune-cronstamps "$pkgdir"/etc/cron.d/prune-cronstamps
+ install -Dm644 "$srcdir"/service "$pkgdir"/usr/lib/systemd/system/dcron.service
+}
diff --git a/service b/service
new file mode 100644
index 000000000000..703f32075c9b
--- /dev/null
+++ b/service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Periodic Command Scheduler
+
+[Service]
+Type=forking
+EnvironmentFile=/etc/conf.d/crond
+ExecStart=/usr/bin/crond $CROND_ARGS
+Restart=always
+
+[Install]
+WantedBy=multi-user.target