summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxaque2022-09-17 04:48:05 -0700
committerxaque2022-09-17 04:48:05 -0700
commit2782353a25e7ffe85a276077061c73444eb20500 (patch)
treefa87401f217d66df6ce63be9b3d6f37654b3280d
parent6aca043a7f7ad50a0de2c3e4377963d9175d38b9 (diff)
downloadaur-2782353a25e7ffe85a276077061c73444eb20500.tar.gz
Roll back version as there is a critical bug in 2022.1 causing downloads to corrupt despite throwing no errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aa687397724..3d18d0cf56a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dcvviewer-bin
pkgdesc = NICE DCV client for Linux. DCV is a desktop remotization server, with support for native as well as web-based clients.
- pkgver = 2022.1.4251
+ pkgver = 2022.0.4131
pkgrel = 1
url = https://www.nice-software.com/products/dcv
arch = x86_64
@@ -31,7 +31,7 @@ pkgbase = dcvviewer-bin
depends = sqlite
depends = zlib
optdepends = openssl3-git: Support for OpenSSL 3.0.0
- source = https://d1uj6qtbmh3dt5.cloudfront.net/2022.1/Clients/nice-dcv-viewer_2022.1.4251-1_amd64.ubuntu2204.deb
- sha256sums = cbd7fa4aec4eca87836bc96cedf8a03d6a9836d8ba8a242b4cc19fa3f0d9d7a7
+ source = https://d1uj6qtbmh3dt5.cloudfront.net/2022.0/Clients/nice-dcv-viewer_2022.0.4131-1_amd64.ubuntu2004.deb
+ sha256sums = SKIP
pkgname = dcvviewer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 20c7202961f0..d8a072c7645f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=dcvviewer-bin
_pkgname=dcvviewer
-_majver=2022.1
-_minver=4251
+_majver=2022.0
+_minver=4131
pkgver=${_majver}.${_minver}
pkgrel=1
pkgdesc="NICE DCV client for Linux. DCV is a desktop remotization server, with support for native as well as web-based clients."
@@ -15,15 +15,15 @@ depends=('cairo' 'dconf' 'desktop-file-utils' 'ffmpeg' 'gdk-pixbuf2' 'glib2' 'gl
# At launch, dcvviewer shows an error looking for OpenSSL 3.0.0 libs, but I haven't noticed any broken features without it
optdepends=('openssl3-git: Support for OpenSSL 3.0.0')
source=(
- "https://d1uj6qtbmh3dt5.cloudfront.net/${_majver}/Clients/nice-dcv-viewer_${pkgver}-1_amd64.ubuntu2204.deb"
+ "https://d1uj6qtbmh3dt5.cloudfront.net/${_majver}/Clients/nice-dcv-viewer_${pkgver}-1_amd64.ubuntu2004.deb"
)
-sha256sums=('cbd7fa4aec4eca87836bc96cedf8a03d6a9836d8ba8a242b4cc19fa3f0d9d7a7')
+sha256sums=('SKIP')
package(){
# Extract package data, move files to comply with Arch package guidelines
# (https://wiki.archlinux.org/index.php/Arch_package_guidelines#Directories)
- tar -xf data.tar.zst -C "${pkgdir}" \
+ tar -xf data.tar.xz -C "${pkgdir}" \
--transform 's,^./usr/lib/x86_64-linux-gnu,./usr/lib,' \
--transform 's,^./usr/libexec,./usr/lib,' \
--transform 's,^./usr/share/dcvviewer/license/EULA.txt,./usr/share/licenses/dcvviewer/EULA,' \
@@ -49,7 +49,7 @@ package(){
# Might want to keep with same version of glib
rm libffi.so.7 libjson-glib-1.0.so.0
# Codecs provided by ffmpeg, gst-plugins-base, lz4, zlib
- rm libavcodec.so.59 libturbojpeg.so.0 libavutil.so.57 libopus.so.0 libjpeg.so.62 liblz4.so.1 libz.so.1
+ rm libavcodec.so.* libturbojpeg.so.0 libavutil.so.* libopus.so.0 libjpeg.so.62 liblz4.so.1 libz.so.1
rm liblmdb.so libprotobuf-c.so.1
# There is no (real) soname 3 for libpcre. Debian may be repsponsible for masquerading soname 0 as 3.
ln -s /usr/lib/libpcre.so libpcre.so.3