summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxaque2023-01-07 02:02:09 -0800
committerxaque2023-01-07 02:02:09 -0800
commit86aeb00530ac25288f5ed615ea84ded3fc980c2b (patch)
tree4b30909656effc6bed344f5b6c837d2b8aa1544c
parent3d278d8ff10cd23fccbe33fdb565cd7009d1c5b2 (diff)
downloadaur-86aeb00530ac25288f5ed615ea84ded3fc980c2b.tar.gz
Updated to 2022.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c573b891632..20dd17684997 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dcvviewer-bin
pkgdesc = NICE DCV client for Linux. DCV is a desktop remotization server, with support for native as well as web-based clients.
- pkgver = 2022.0.4131
+ pkgver = 2022.2.4804
pkgrel = 1
url = https://www.nice-software.com/products/dcv
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = dcvviewer-bin
depends = cairo
depends = dconf
depends = desktop-file-utils
- depends = ffmpeg4.4
+ depends = ffmpeg
depends = gdk-pixbuf2
depends = glib2
depends = glibc
@@ -26,12 +26,12 @@ pkgbase = dcvviewer-bin
depends = lz4
depends = nss
depends = pango
+ depends = pcre
depends = pcsclite
depends = protobuf-c
depends = sqlite
depends = zlib
- optdepends = openssl3-git: Support for OpenSSL 3.0.0
- source = https://d1uj6qtbmh3dt5.cloudfront.net/2022.0/Clients/nice-dcv-viewer_2022.0.4131-1_amd64.ubuntu2004.deb
+ source = https://d1uj6qtbmh3dt5.cloudfront.net/2022.2/Clients/nice-dcv-viewer_2022.2.4804-1_amd64.ubuntu2204.deb
sha256sums = SKIP
pkgname = dcvviewer-bin
diff --git a/PKGBUILD b/PKGBUILD
index e418a3cae690..e1453d43454b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,18 @@
pkgname=dcvviewer-bin
_pkgname=dcvviewer
-_majver=2022.0
-_minver=4131
+_majver=2022.2
+_minver=4804
pkgver=${_majver}.${_minver}
pkgrel=1
pkgdesc="NICE DCV client for Linux. DCV is a desktop remotization server, with support for native as well as web-based clients."
arch=('x86_64')
url="https://www.nice-software.com/products/dcv"
license=('custom: commercial')
-depends=('cairo' 'dconf' 'desktop-file-utils' 'ffmpeg4.4' 'gdk-pixbuf2' 'glib2' 'glibc' 'graphite' 'gst-plugins-base' 'gstreamer' 'gtk3' 'krb5' 'libepoxy' 'libjpeg6' 'libsasl' 'libsoup' 'libx11' 'lmdb' 'lz4' 'nss' 'pango' 'pcsclite' 'protobuf-c' 'sqlite' 'zlib')
-# At launch, dcvviewer shows an error looking for OpenSSL 3.0.0 libs, but I haven't noticed any broken features without it
-optdepends=('openssl3-git: Support for OpenSSL 3.0.0')
+depends=('cairo' 'dconf' 'desktop-file-utils' 'ffmpeg' 'gdk-pixbuf2' 'glib2' 'glibc' 'graphite' 'gst-plugins-base' 'gstreamer' 'gtk3' 'krb5' 'libepoxy' 'libjpeg6' 'libsasl' 'libsoup' 'libx11' 'lmdb' 'lz4' 'nss' 'pango' 'pcre' 'pcsclite' 'protobuf-c' 'sqlite' 'zlib'
+)
source=(
- "https://d1uj6qtbmh3dt5.cloudfront.net/${_majver}/Clients/nice-dcv-viewer_${pkgver}-1_amd64.ubuntu2004.deb"
+ "https://d1uj6qtbmh3dt5.cloudfront.net/${_majver}/Clients/nice-dcv-viewer_${pkgver}-1_amd64.ubuntu2204.deb"
)
sha256sums=('SKIP')
@@ -23,7 +22,7 @@ package(){
# Extract package data, move files to comply with Arch package guidelines
# (https://wiki.archlinux.org/index.php/Arch_package_guidelines#Directories)
- tar -xf data.tar.xz -C "${pkgdir}" \
+ tar -xf data.tar.zst -C "${pkgdir}" \
--transform 's,^./usr/lib/x86_64-linux-gnu,./usr/lib,' \
--transform 's,^./usr/libexec,./usr/lib,' \
--transform 's,^./usr/share/dcvviewer/license/EULA.txt,./usr/share/licenses/dcvviewer/EULA,' \
@@ -47,12 +46,12 @@ package(){
# Provided by glib2
rm libglib-2.0.so.0 libgmodule-2.0.so.0 libgobject-2.0.so.0 libgthread-2.0.so.0 libgio-2.0.so.0
# Might want to keep with same version of glib
- rm libffi.so.7 libjson-glib-1.0.so.0
+ rm libffi.so.* libjson-glib-1.0.so.0
# Codecs provided by ffmpeg, gst-plugins-base, lz4, zlib
rm libavcodec.so.* libturbojpeg.so.0 libavutil.so.* libopus.so.0 libjpeg.so.62 liblz4.so.1 libz.so.1
rm liblmdb.so libprotobuf-c.so.1
- # There is no (real) soname 3 for libpcre. Debian may be repsponsible for masquerading soname 0 as 3.
- ln -s /usr/lib/libpcre.so libpcre.so.3
+ #
+ rm libpcre.so.1
# Keep these ones provided by DCV Viewer. There are symbols being looked up in the provided libsoup-3 not in the system one
#rm libsasl2.so.3 libsoup-3.0.so.0
# libsoup deps