summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBence Hornák2020-06-01 12:05:34 +0200
committerBence Hornák2020-06-01 12:05:34 +0200
commitda2bab9a04ffbcf0992402fc4551594c265cd2cf (patch)
tree446a975b573982fc7c1e7011d82239aade00c801
downloadaur-da2bab9a04ffbcf0992402fc4551594c265cd2cf.tar.gz
Version 2020.0.1358-1
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD33
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f64640e3a53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = dcvviewer-bin
+ pkgdesc = DCV Desktop Cloud Visualization GTK client for Linux. DCV is a desktop remotization server, with support for native as well as web-based clients.
+ pkgver = 2020.0.1358
+ pkgrel = 1
+ url = https://www.nice-software.com/products/dcv
+ arch = x86_64
+ license = custom: commercial
+ depends = backintime
+ depends = cairo>=1.10.0
+ depends = dconf
+ depends = desktop-file-utils
+ depends = ffmpeg
+ depends = gcc-libs>=4.2
+ depends = gdk-pixbuf2>=2.22.0
+ depends = glib2
+ depends = glibc>=2.18
+ depends = gst-plugins-base-libs>=1.0.0
+ depends = gstreamer>=1.0.0
+ depends = gtk3>=3.21.4
+ depends = hicolor-icon-theme
+ depends = krb5>=1.16
+ depends = libepoxy>=1.0
+ depends = libjpeg-turbo
+ depends = libsasl
+ depends = libsoup
+ depends = libva>=1.8.0
+ depends = libx11
+ depends = libxml2>=2.7.4
+ depends = lz4
+ depends = openssl>=1.1.0
+ depends = pango
+ depends = pcsclite>=1.3.0
+ depends = protobuf-c
+ depends = sqlite>=3.5.9
+ source = https://d1uj6qtbmh3dt5.cloudfront.net/2020.0/Clients/nice-dcv-viewer_2020.0.1358-1_amd64.ubuntu1804.deb
+ sha256sums = b41820f54a8e3e5e820cc32aa08b4e9079508f654134ec3b69a2eace62c66bf4
+
+pkgname = dcvviewer-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bb0ec250e5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Bence Hornák <bence.hornak@gmail.com>
+
+pkgname=dcvviewer-bin
+_pkgname=dcvviewer
+pkgver=2020.0.1358
+pkgrel=1
+pkgdesc="DCV Desktop Cloud Visualization GTK client for Linux. DCV is a desktop remotization server, with support for native as well as web-based clients."
+arch=('x86_64')
+url="https://www.nice-software.com/products/dcv"
+license=('custom: commercial')
+depends=('backintime' 'cairo>=1.10.0' 'dconf' 'desktop-file-utils' 'ffmpeg' 'gcc-libs>=4.2' 'gdk-pixbuf2>=2.22.0' 'glib2' 'glibc>=2.18' 'gst-plugins-base-libs>=1.0.0' 'gstreamer>=1.0.0' 'gtk3>=3.21.4' 'hicolor-icon-theme' 'krb5>=1.16' 'libepoxy>=1.0' 'libjpeg-turbo' 'libsasl' 'libsoup' 'libva>=1.8.0' 'libx11' 'libxml2>=2.7.4' 'lz4' 'openssl>=1.1.0' 'pango' 'pcsclite>=1.3.0' 'protobuf-c' 'sqlite>=3.5.9')
+source=(
+ "https://d1uj6qtbmh3dt5.cloudfront.net/2020.0/Clients/nice-dcv-viewer_${pkgver}-1_amd64.ubuntu1804.deb"
+)
+sha256sums=('b41820f54a8e3e5e820cc32aa08b4e9079508f654134ec3b69a2eace62c66bf4')
+
+package(){
+
+ # Extract package data
+ tar -xf data.tar.xz -C "${pkgdir}" \
+ --transform 's,^./usr/lib/x86_64-linux-gnu,./usr/lib,' \
+ --transform 's,^./usr/libexec,./usr/lib,' \
+ --transform 's,^./usr/share/dcvviewer/license/EULA.txt,./usr/share/licenses/dcvviewer/EULA,' \
+ --transform 's,^./usr/share/dcvviewer\(/license\)\?$,.,' \
+ --transform 's,^./usr/share/dcvviewer/third-party-licenses.txt,./usr/share/licenses/dcvviewer/LICENSE,' \
+ --transform 's,^./usr/share/doc/nice-dcv-viewer/copyright,./usr/share/licenses/dcvviewer/COPYRIGHT,' \
+ --transform 's,^./usr/share/doc\(/nice-dcv-viewer\)\?$,.,' \
+ --exclude './usr/share/doc/nice-dcv-viewer/changelog.Debian.gz'
+
+ sed -i 's|libdir=${basedir}/lib/x86_64-linux-gnu|libdir=${basedir}/lib|; s|libexecdir=${basedir}/libexec|libexecdir=${basedir}/lib|' \
+ "${pkgdir}/usr/bin/dcvviewer"
+
+}