summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-08-19 16:05:47 +0200
committerKrzysztof (3ED) AS2015-08-19 16:05:47 +0200
commite7547b077f67f78e8e666d2fd0094076bb25122b (patch)
treee08521ad24cc71980ae24c7069aa7f208e795e61
downloadaur-e7547b077f67f78e8e666d2fd0094076bb25122b.tar.gz
Initial on aur4
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD55
-rw-r--r--ddccontrol.install10
-rw-r--r--org.ddccontrol.pkexec.gddccontrol.policy22
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd06b39e61ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ddccontrol
+ pkgdesc = Control your monitor by software using the DDC/CI protocol
+ pkgver = 0.4.2
+ pkgrel = 4
+ url = http://ddccontrol.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = pciutils
+ depends = ddccontrol-db
+ depends = perl-xml-parser
+ options = !libtool
+ source = http://downloads.sourceforge.net/ddccontrol/ddccontrol-0.4.2.tar.bz2
+ source = org.ddccontrol.pkexec.gddccontrol.policy
+ sha256sums = 986f3b4b27ec04e1da493de3aaab01cd5ea9566d7572c1a40b8d43cd7a491e84
+ sha256sums = 811bf1ecc85045e80757ea553591c00e32bb93d529a761b18bb501d0f2bf82c5
+
+pkgname = ddccontrol
+ install = ddccontrol.install
+
+pkgname = gddccontrol
+ pkgdesc = Control your monitor by software using the DDC/CI protocol (GUI)
+ depends = gtk2
+ depends = ddccontrol
+ conflicts = ddccontrol-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d77669fe224d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: 3ED_0 <krzysztof1987 /at/ gmail.com>
+# Contributor: kfgz <kfgz at interia pl>
+# Contributor: Hubert CzobodziƄski <hcz at onet dot eu>
+# Contributor: Nathan Owe <ndowens dot aur at gmail dot com>
+
+pkgbase=ddccontrol
+pkgname=(ddccontrol gddccontrol)
+pkgver=0.4.2
+pkgrel=4
+pkgdesc="Control your monitor by software using the DDC/CI protocol"
+arch=('i686' 'x86_64')
+url="http://ddccontrol.sourceforge.net/"
+license=('GPL')
+depends=('pciutils' 'ddccontrol-db' 'perl-xml-parser')
+source=("http://downloads.sourceforge.net/${pkgbase}/${pkgbase}-${pkgver}.tar.bz2"
+ "org.ddccontrol.pkexec.gddccontrol.policy")
+options=('!libtool')
+sha256sums=('986f3b4b27ec04e1da493de3aaab01cd5ea9566d7572c1a40b8d43cd7a491e84'
+ '811bf1ecc85045e80757ea553591c00e32bb93d529a761b18bb501d0f2bf82c5')
+
+prepare() {
+ sed -e 's/Exec=gddccontrol/Exec=pkexec gddccontrol/' \
+ -i "${srcdir}/${pkgbase}-${pkgver}/src/gddccontrol/gddccontrol.desktop"
+}
+
+build() {
+ cd "${srcdir}"/${pkgbase}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --disable-gnome-applet
+ make
+}
+
+package_ddccontrol() {
+ install=ddccontrol.install
+ cd "${srcdir}"/${pkgbase}-${pkgver}
+ for i in src/lib src/ddcpci src/ddccontrol po man doc; do
+ make DESTDIR="${pkgdir}" install -C $i
+ done
+
+ chmod 755 "${pkgdir}"/usr/bin/ddcpci
+}
+
+package_gddccontrol() {
+ depends=('gtk2' 'ddccontrol')
+ pkgdesc="Control your monitor by software using the DDC/CI protocol (GUI)"
+ conflicts=("ddccontrol-git")
+
+ cd "${srcdir}"/${pkgbase}-${pkgver}
+ make DESTDIR="${pkgdir}" install -C src/gddccontrol
+
+ install -Dm644 \
+ "$srcdir/org.ddccontrol.pkexec.gddccontrol.policy" \
+ "${pkgdir}/usr/share/polkit-1/actions/org.ddccontrol.pkexec.gddccontrol.policy"
+}
diff --git a/ddccontrol.install b/ddccontrol.install
new file mode 100644
index 000000000000..4d1cce505fea
--- /dev/null
+++ b/ddccontrol.install
@@ -0,0 +1,10 @@
+post_install() {
+ cat <<EOF
+For some of nvidia proprietary driver users will be necessary to add this:
+ >> Option "RegistryDwords" "RMUseSwI2c=0x01; RMI2cSpeed=100"
+to "Device" section in:
+ >> /etc/X11/xorg.conf.d/20-nvidia.conf
+or similar place.
+EOF
+}
+post_install
diff --git a/org.ddccontrol.pkexec.gddccontrol.policy b/org.ddccontrol.pkexec.gddccontrol.policy
new file mode 100644
index 000000000000..4f1030123f80
--- /dev/null
+++ b/org.ddccontrol.pkexec.gddccontrol.policy
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE policyconfig PUBLIC
+ "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
+<policyconfig>
+ <vendor>DDCcontrol</vendor>
+ <vendor_url>http://ddccontrol.sourceforge.net/</vendor_url>
+
+ <action id="org.ddccontrol.pkexec.gddccontrol">
+ <message>Authentication is required to run the Monitor Settings</message>
+ <icon_name>gddccontrol</icon_name>
+ <defaults>
+ <allow_any>no</allow_any>
+ <allow_inactive>no</allow_inactive>
+ <allow_active>yes</allow_active>
+ </defaults>
+ <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/gddccontrol</annotate>
+ <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
+ </action>
+
+</policyconfig>
+