summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjsteel2014-02-28 21:44:56 +0000
committersvntogit2014-02-28 21:44:56 +0000
commite06d2a4e0f921c2dffd297019813f3362afcfd60 (patch)
treec5308309b4a65dc7b57c9542f97d5ae7aeadaffb
parentf01912d25622af0f7fdf3a044b7b0f0e9deb97f4 (diff)
downloadaur-e06d2a4e0f921c2dffd297019813f3362afcfd60.tar.gz
upgpkg: ddclient 3.8.2-1
git-svn-id: file:///srv/repos/svn-community/svn@106349 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
-rw-r--r--ddclient.install19
-rw-r--r--iproute2.patch29
-rw-r--r--usrbin.patch13
5 files changed, 24 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54851f2a890e..d207fe394ffe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
pkgbase = ddclient
pkgdesc = Update dynamic DNS entries for accounts on many dynamic DNS services
- pkgver = 3.8.1
- pkgrel = 8
+ pkgver = 3.8.2
+ pkgrel = 1
url = http://ddclient.sourceforge.net
- install = ddclient.install
arch = any
license = GPL2
depends = perl-io-socket-ssl
depends = perl-digest-sha1
+ depends = net-tools
backup = etc/ddclient/ddclient.conf
- source = http://downloads.sourceforge.net/sourceforge/ddclient/ddclient-3.8.1.tar.bz2
+ source = http://downloads.sourceforge.net/sourceforge/ddclient/ddclient-3.8.2.tar.bz2
source = ddclient.service
- source = iproute2.patch
- source = usrbin.patch
- md5sums = 7fa417bc65f8f0e6ce78418a4f631988
- md5sums = a649273dd12540defaa296bf9d2a3174
- md5sums = e0c8a07e9b7a69e73cecd8626f16e8f0
- md5sums = 65e294485a18b8d3f752a124913579f1
+ md5sums = 62cd5fe93ced2c794d5f441f9d908841
+ md5sums = 1bcd3e75309e658931532adef2a0608a
pkgname = ddclient
diff --git a/PKGBUILD b/PKGBUILD
index b877c5d69ae6..91f7baa7c807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,34 @@
# $Id$
-# Maintainer: Jonathan Steel <mail@jsteel.org>
+# Maintainer: Jonathan Steel <jsteel@aur.archlinux.org>
# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
# Contributor: David Rosenstrauch <darose@darose.net>
pkgname=ddclient
-pkgver=3.8.1
-pkgrel=8
+pkgver=3.8.2
+pkgrel=1
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services"
arch=('any')
url="http://ddclient.sourceforge.net"
license=('GPL2')
-depends=('perl-io-socket-ssl' 'perl-digest-sha1')
+depends=('perl-io-socket-ssl' 'perl-digest-sha1' 'net-tools')
backup=('etc/ddclient/ddclient.conf')
-install=ddclient.install
source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
- ddclient.service
- iproute2.patch
- usrbin.patch)
-md5sums=('7fa417bc65f8f0e6ce78418a4f631988'
- 'a649273dd12540defaa296bf9d2a3174'
- 'e0c8a07e9b7a69e73cecd8626f16e8f0'
- '65e294485a18b8d3f752a124913579f1')
-
-prepare() {
- cd "$srcdir"/ddclient-$pkgver
-
- patch -Np1 -i "$srcdir"/iproute2.patch
- patch -Np0 -i "$srcdir"/usrbin.patch
-}
+ $pkgname.service)
+md5sums=('62cd5fe93ced2c794d5f441f9d908841'
+ '1bcd3e75309e658931532adef2a0608a')
package() {
- cd "$srcdir"/ddclient-$pkgver
+ cd "$srcdir"/$pkgname-$pkgver
- # core files
- install -Dm755 ddclient "$pkgdir"/usr/bin/ddclient
- install -Dm600 sample-etc_ddclient.conf "$pkgdir"/etc/ddclient/ddclient.conf
- install -d "$pkgdir"/var/cache/ddclient
-
- # additional instructions, sample configs
- install -Dm644 README "$pkgdir"/etc/ddclient/samples/README
- install -Dm644 sample-etc_cron.d_ddclient "$pkgdir"/etc/ddclient/samples/sample-etc_cron.d_ddclient
- install -Dm644 sample-etc_dhcpc_dhcpcd-eth0.exe "$pkgdir"/etc/ddclient/samples/sample-etc_dhcpc_dhcpcd-eth0.exe
- install -Dm644 sample-etc_ppp_ip-up.local "$pkgdir"/etc/ddclient/samples/sample-etc_ppp_ip-up.local
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm600 sample-etc_$pkgname.conf "$pkgdir"/etc/$pkgname/$pkgname.conf
+ install -d "$pkgdir"/var/cache/$pkgname
install -Dm644 "$srcdir"/$pkgname.service "$pkgdir"/usr/lib/systemd/system/$pkgname.service
+
+ install -Dm644 README.cisco "$pkgdir"/usr/share/doc/$pkgname/README.cisco
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+ install -Dm644 README.ssl "$pkgdir"/usr/share/doc/$pkgname/README.ssl
+ install -Dm644 sample-etc_cron.d_$pkgname "$pkgdir"/usr/share/doc/$pkgname/sample-etc_cron.d_$pkgname
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
}
diff --git a/ddclient.install b/ddclient.install
deleted file mode 100644
index f2f965b0b869..000000000000
--- a/ddclient.install
+++ /dev/null
@@ -1,19 +0,0 @@
-# arg 1: the new package version
-post_install() {
-cat << EOM
-
-If you want to use ddclient with dhcpcd, cron or pppd,
-see /etc/ddclient/samples for further instructions.
-
-EOM
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
-if [ -f /etc/ddclient/ddclient.cache ]; then
- echo -n "Moving ddclient.cache from /etc/ddclient/ to /var/cache/ddclient/."
- mv /etc/ddclient/ddclient.cache /var/cache/ddclient/
- echo " (done)"
-fi
-}
diff --git a/iproute2.patch b/iproute2.patch
deleted file mode 100644
index 76c818325994..000000000000
--- a/iproute2.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/ddclient.orig 2012-02-17 13:12:29.000000000 +0000
-+++ b/ddclient 2012-02-27 13:03:02.357329432 +0000
-@@ -588,7 +588,7 @@
- [ "ip", "=s", "-ip address : set the IP address to 'address'" ],
- "",
- [ "if", "=s", "-if interface : obtain IP address from 'interface'" ],
-- [ "if-skip", "=s", "-if-skip pattern : skip any IP addresses before 'pattern' in the output of ifconfig {if}" ],
-+ [ "if-skip", "=s", "-if-skip pattern : skip any IP addresses before 'pattern' in the output of ip addr show {if}" ],
- "",
- [ "web", "=s", "-web provider|url : obtain IP address from provider's IP checking page" ],
- [ "web-skip", "=s", "-web-skip pattern : skip any IP addresses before 'pattern' on the web provider|url" ],
-@@ -1316,7 +1316,7 @@
-
- {
- local $opt{'use'} = 'if';
-- foreach my $if (grep {/^[a-zA-Z]/} `ifconfig -a`) {
-+ foreach my $if (grep {/^[a-zA-Z]/} `ip addr show`) {
- $if =~ s/:?\s.*//is;
- local $opt{'if'} = $if;
- printf "use=if, if=%s address is %s\n", opt('if'), define(get_ip('if'), 'NOT FOUND');
-@@ -1937,7 +1937,7 @@
-
- } elsif ($use eq 'if') {
- $skip = opt('if-skip', $h) || '';
-- $reply = `ifconfig $arg 2> /dev/null`;
-+ $reply = `ip addr show $arg 2> /dev/null`;
- $reply = '' if $?;
-
- } elsif ($use eq 'cmd') {
diff --git a/usrbin.patch b/usrbin.patch
deleted file mode 100644
index 1ee90c5430cd..000000000000
--- a/usrbin.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- sample-etc_cron.d_ddclient.orig 2013-05-12 13:04:10.958327840 +0100
-+++ sample-etc_cron.d_ddclient 2013-05-12 13:04:38.588178156 +0100
-@@ -10,8 +10,8 @@
- ######################################################################
- ## force an update twice a month (only if you are not using daemon-mode)
- ##
--## 30 23 1,15 * * root /usr/sbin/ddclient -daemon=0 -syslog -quiet -force
-+## 30 23 1,15 * * root /usr/bin/ddclient -daemon=0 -syslog -quiet -force
- ######################################################################
- ## retry failed updates every hour (only if you are not using daemon-mode)
- ##
--## 0 * * * * root /usr/sbin/ddclient -daemon=0 -syslog -quiet retry
-+## 0 * * * * root /usr/bin/ddclient -daemon=0 -syslog -quiet retry