summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiha Frangež2020-07-10 17:37:51 +0200
committerMiha Frangež2020-07-10 17:37:51 +0200
commit617f8d66edf47c382bc4ff3c0931a2de64c1d24d (patch)
tree7b161eb40396908c21581934de717427ab3806e1
downloadaur-617f8d66edf47c382bc4ff3c0931a2de64c1d24d.tar.gz
First package for ddcui
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--ddcui.desktop7
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e876ec4038eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ddcui-git
+ pkgdesc = ddcui is a beta version of a graphical user interface for ddcutil, implemented using Qt.
+ pkgver = v0.1.2.r0.g46dba4e
+ pkgrel = 1
+ url = https://www.ddcutil.com/ddcui_main/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = ddcutil-git
+ depends = qt5-base
+ provides = ddcui
+ source = git+https://github.com/rockowitz/ddcui
+ source = ddcui.desktop
+ sha256sums = SKIP
+ sha256sums = dfc636ed820339094226fe6b4e9f855206125390a2f2c7e356a54c21008a3033
+
+pkgname = ddcui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d48cd1404195
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Miha Frangež <miha.frangez at gmail dot com>
+
+_pkgname=ddcui
+pkgname=ddcui-git
+pkgver=v0.1.2.r0.g46dba4e
+pkgrel=1
+pkgdesc='ddcui is a beta version of a graphical user interface for ddcutil, implemented using Qt.'
+url='https://www.ddcutil.com/ddcui_main/'
+license=('GPL2')
+source=(
+ 'git+https://github.com/rockowitz/ddcui'
+ ddcui.desktop
+)
+sha256sums=(
+ 'SKIP'
+ 'dfc636ed820339094226fe6b4e9f855206125390a2f2c7e356a54c21008a3033'
+)
+arch=('i686' 'x86_64')
+provides=('ddcui')
+
+depends=(
+ 'ddcutil-git'
+ 'qt5-base'
+)
+
+makedepends=(
+ 'git'
+ 'cmake'
+)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ cmake \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=release \
+ .
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m664 ../ddcui.desktop $pkgdir/usr/share/applications/ddcui.desktop
+}
diff --git a/ddcui.desktop b/ddcui.desktop
new file mode 100644
index 000000000000..e245d66ed584
--- /dev/null
+++ b/ddcui.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=ddcui
+GenericName=Control Monitor Settings
+Type=Application
+Exec=ddcui
+Icon=preferences-desktop-display-color.png
+Categories=Settings;HardwareSettings;