summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeon Spengler2017-05-02 08:31:48 +0200
committerDeon Spengler2017-05-02 08:31:48 +0200
commiteca4ec1a7c15d5de7d7b1a981fa37faba57c0a27 (patch)
tree94e46c80f103186f7274ec766390a7cb33061f8f
downloadaur-eca4ec1a7c15d5de7d7b1a981fa37faba57c0a27.tar.gz
Update to ddcutil-0.8.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25b1f3938d02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ddcutil
+ pkgdesc = Query and change Linux monitor settings using DDC/CI and USB.
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = http://ddcutil.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ conflicts = ddcutil-git
+ source = https://github.com/rockowitz/ddcutil/archive/v0.8.0.tar.gz
+ sha256sums = 487c87f0dc686c98d1196205d384aa2c73dc3ccefbe06d46193618812a6bc3cd
+
+pkgname = ddcutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed79151e4155
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Deon Spengler <deon[at]spengler[dot]co[dot]za>
+
+pkgname=ddcutil
+pkgver=0.8.0
+pkgrel=1
+pkgdesc='Query and change Linux monitor settings using DDC/CI and USB.'
+url='http://ddcutil.com/'
+license=('GPL')
+conflicts=('ddcutil-git')
+source=(https://github.com/rockowitz/ddcutil/archive/v${pkgver}.tar.gz)
+sha256sums=('487c87f0dc686c98d1196205d384aa2c73dc3ccefbe06d46193618812a6bc3cd')
+arch=('i686' 'x86_64')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ft=sh ts=2 sw=2 et