summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormotte2020-04-25 23:53:02 +0300
committermotte2020-04-25 23:53:02 +0300
commit4c4a76c085cf8db8265d0b17f121d8fc3ae43c25 (patch)
tree36e408bf0ae3813c083a8d73c8ba47298fb0cc4f
parentf4b70a0d6108b4732d41d0a0b3fd5d08a082d4ae (diff)
downloadaur-4c4a76c085cf8db8265d0b17f121d8fc3ae43c25.tar.gz
Use dev branch, add depends and more
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 28 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3c28d0430da..1c07567a187c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
-# Generated by mksrcinfo v8
-# Thu Mar 2 05:08:56 UTC 2017
pkgbase = ddcutil-git
pkgdesc = Query and change Linux monitor settings using DDC/CI and USB (development version).
- pkgver = v0.7.2.r0.g02a0433
+ pkgver = v0.9.8.r262.g4685e63c
pkgrel = 1
url = http://ddcutil.com/
arch = i686
arch = x86_64
- license = GPL
- source = git+https://github.com/rockowitz/ddcutil
+ license = GPL2
+ makedepends = git
+ depends = libdrm
+ depends = libusb
+ depends = glib2
+ depends = libdrm
+ depends = libgudev
+ depends = libxrandr
+ source = git+https://github.com/rockowitz/ddcutil.git#branch=0.9.9-dev
sha256sums = SKIP
pkgname = ddcutil-git
diff --git a/PKGBUILD b/PKGBUILD
index 8633a2680640..68d9d49a7262 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,43 @@
-# Maintainer: Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
+# Maintainer: motte <ettom22 at hotmail dot com>
+# Contributor: Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
_pkgname=ddcutil
pkgname=ddcutil-git
-pkgver=v0.7.2.r0.g02a0433
+pkgver=v0.9.8.r262.g4685e63c
pkgrel=1
pkgdesc='Query and change Linux monitor settings using DDC/CI and USB (development version).'
url='http://ddcutil.com/'
-license=('GPL')
-source=('git+https://github.com/rockowitz/ddcutil')
+license=('GPL2')
+source=('git+https://github.com/rockowitz/ddcutil.git#branch=0.9.9-dev')
sha256sums=('SKIP')
arch=('i686' 'x86_64')
+depends=(
+ 'libdrm'
+ 'libusb'
+ 'glib2'
+ 'libdrm'
+ 'libgudev'
+ 'libxrandr')
+
+makedepends=(
+ 'git'
+)
+
pkgver() {
cd "${srcdir}/${_pkgname}"
-
- # Get the version number.
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${srcdir}/${_pkgname}"
-
- # Generate the build configuration.
./autogen.sh
- # Configure the build.
./configure --prefix=/usr
-
- # Build it!
make
}
package() {
cd "${srcdir}/${_pkgname}"
-
- # Install the program.
make DESTDIR="${pkgdir}" install
}