summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorpheusthewhite2023-05-13 09:17:28 +0200
committermorpheusthewhite2023-05-13 09:17:28 +0200
commit2ad04f4f2e11fd6886787558af2f50de18ed6773 (patch)
tree89da5c64e2d732e0916d9f27eacca5792176a8e1
parent71a9e8a02b9899b16e043077d5a613b8b9b99d74 (diff)
downloadaur-ddd.tar.gz
Update to 3.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
-rw-r--r--ddd-3.3.12-gcc44.patch10
-rw-r--r--friends.patch68
4 files changed, 9 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae44d72bdda9..4c7ff2435efe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddd
pkgdesc = A graphical front-end for command-line debuggers such as GDB, JDB, pydb, perl debugger...
- pkgver = 3.3.12
+ pkgver = 3.4.0
pkgrel = 12
url = http://www.gnu.org/software/ddd/
arch = x86_64
@@ -13,15 +13,7 @@ pkgbase = ddd
optdepends = java-runtime-openjdk: to use the Java debugger
optdepends = pydb: to use the Python debugger
optdepends = perl: to use the Perl debugger
- source = http://ftp.gnu.org/gnu/ddd/ddd-3.3.12.tar.gz
- source = http://ftp.gnu.org/gnu/ddd/ddd-3.3.12.tar.gz.sig
- source = ddd-3.3.12-gcc44.patch
- source = friends.patch
- validpgpkeys = 4B286694DE99D517AA8DFF2D6656C593E5158D1A
- sha1sums = b91d2dfb1145af409138bd34517a898341724e56
- sha1sums = de155d812da6e11e55cc882292bb5c7b30bd31a1
- sha1sums = 3d43c9d56347f248732b1d72f29c7bf799f03864
- sha1sums = 4fcb220ed3f2b84b9f6a9090a7e147341ed98ee2
+ source = http://ftp.gnu.org/gnu/ddd/ddd-3.4.0.tar.gz
+ sha1sums = cf01bd6727a2b957ae27796bb807298bb34fbbb0
pkgname = ddd
-
diff --git a/PKGBUILD b/PKGBUILD
index 2138275bda85..3529c3dc989a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: morpheusthewhite <zffromGerace@hotmail.it>
pkgname=ddd
-pkgver=3.3.12
+pkgver=3.4.0
pkgrel=12
pkgdesc="A graphical front-end for command-line debuggers such as GDB, JDB, pydb, perl debugger..."
arch=('x86_64')
@@ -10,20 +10,14 @@ url="http://www.gnu.org/software/ddd/"
license=('GPL3' 'LGPL3')
depends=('gcc-libs' 'openmotif' 'libxaw')
optdepends=('gdb: to use the Gnu debugger'
- 'java-runtime-openjdk: to use the Java debugger'
- 'pydb: to use the Python debugger'
- 'perl: to use the Perl debugger')
-source=(http://ftp.gnu.org/gnu/ddd/${pkgname}-${pkgver}.tar.gz{,.sig} ddd-3.3.12-gcc44.patch friends.patch)
-sha1sums=('b91d2dfb1145af409138bd34517a898341724e56'
- 'de155d812da6e11e55cc882292bb5c7b30bd31a1'
- '3d43c9d56347f248732b1d72f29c7bf799f03864'
- '4fcb220ed3f2b84b9f6a9090a7e147341ed98ee2')
-validpgpkeys=('4B286694DE99D517AA8DFF2D6656C593E5158D1A')
+ 'java-runtime-openjdk: to use the Java debugger'
+ 'pydb: to use the Python debugger'
+ 'perl: to use the Perl debugger')
+source=(http://ftp.gnu.org/gnu/ddd/${pkgname}-${pkgver}.tar.gz)
+sha1sums=('cf01bd6727a2b957ae27796bb807298bb34fbbb0')
prepare() {
cd ${pkgname}-${pkgver}
- patch -p1 -i "${srcdir}/ddd-3.3.12-gcc44.patch"
- patch -p1 -i "${srcdir}/friends.patch"
}
build() {
diff --git a/ddd-3.3.12-gcc44.patch b/ddd-3.3.12-gcc44.patch
deleted file mode 100644
index 2464b2b4a9c4..000000000000
--- a/ddd-3.3.12-gcc44.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ddd-3.3.12-orig/ddd/strclass.C
-+++ ddd-3.3.12/ddd/strclass.C
-@@ -39,6 +39,7 @@
- #include <limits.h>
- #include <new>
- #include <stdlib.h>
-+#include <stdio.h>
-
- void string::error(const char* msg) const
- {
diff --git a/friends.patch b/friends.patch
deleted file mode 100644
index 4175f4ad70a8..000000000000
--- a/friends.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- ddd-3.3.12-orig/ddd/strclass.C
-+++ ddd-3.3.12/ddd/strclass.C
-index 7ef16fa..faea640 100644
---- i/ddd/strclass.h
-+++ w/ddd/strclass.h
-@@ -810,10 +810,10 @@ public:
- friend int split(const string& x, string *res, int maxn,
- const regex& sep);
-
-- friend string common_prefix(const string& x, const string& y,
-- int startpos = 0);
-- friend string common_suffix(const string& x, const string& y,
-- int startpos = -1);
-+ inline string common_prefix(const string& x, const string& y);
-+ friend string common_prefix(const string& x, const string& y, int startpos);
-+ inline string common_suffix(const string& x, const string& y);
-+ friend string common_suffix(const string& x, const string& y, int startpos);
- friend string replicate(char c, int n);
- friend string replicate(const string& y, int n);
- friend string join(const string *src, int n, const string& sep);
-@@ -863,9 +863,10 @@ public:
- friend inline std::ostream& operator<<(std::ostream& s, const subString& x);
- friend std::istream& operator>>(std::istream& s, string& x);
-
-- friend int readline(std::istream& s, string& x,
-- char terminator = '\n',
-- int discard_terminator = 1);
-+ inline int readline(std::istream& s, string& x);
-+ inline int readline(std::istream& s, string& x, char terminator);
-+ friend int readline(std::istream& s, string& x, char terminator,
-+ int discard_terminator);
-
- // Status
- unsigned int length() const;
-@@ -1456,6 +1457,16 @@ inline string operator + (char x, const subString& y)
- string r; cat(x, y, r); return r;
- }
-
-+inline string common_prefix(const string& x, const string& y)
-+{
-+ return common_prefix(x, y, 0);
-+}
-+
-+inline string common_suffix(const string& x, const string& y)
-+{
-+ return common_suffix(x, y, -1);
-+}
-+
- inline string reverse(const string& x)
- {
- string r; r.rep = string_Sreverse(x.rep, r.rep); return r;
-@@ -1476,6 +1487,16 @@ inline string capitalize(const string& x)
- string r; r.rep = string_Scapitalize(x.rep, r.rep); return r;
- }
-
-+inline int readline(std::istream& s, string& x)
-+{
-+ return readline(s, x, '\n', 1);
-+}
-+
-+inline int readline(std::istream& s, string& x, char terminator)
-+{
-+ return readline(s, x, terminator, 1);
-+}
-+
- // prepend
-
- inline string& string::prepend(const string& y)