summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-11-23 07:10:24 +0000
committerAntonio Rojas2017-11-23 07:10:24 +0000
commit405ee61df38f38cbfbba49f5a0a78a7817b90344 (patch)
tree21778417bf2ac4c80347c2b300e883831a25fffe
downloadaur-405ee61df38f38cbfbba49f5a0a78a7817b90344.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
-rw-r--r--ddd-3.3.12-gcc44.patch10
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..924cfc9ff882
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ddd
+ pkgdesc = A graphical front-end for command-line debuggers such as GDB, JDB, pydb, perl debugger...
+ pkgver = 3.3.12
+ pkgrel = 10
+ url = http://www.gnu.org/software/ddd/
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ depends = gcc-libs
+ depends = openmotif
+ depends = libxaw
+ optdepends = gdb: to use the Gnu debugger
+ optdepends = java-runtime-openjdk: to use the Java debugger
+ optdepends = pydb: to use the Python debugger
+ optdepends = perl: to use the Perl debugger
+ source = http://ftp.gnu.org/gnu/ddd/ddd-3.3.12.tar.gz
+ source = http://ftp.gnu.org/gnu/ddd/ddd-3.3.12.tar.gz.sig
+ source = ddd-3.3.12-gcc44.patch
+ validpgpkeys = 4B286694DE99D517AA8DFF2D6656C593E5158D1A
+ sha1sums = b91d2dfb1145af409138bd34517a898341724e56
+ sha1sums = de155d812da6e11e55cc882292bb5c7b30bd31a1
+ sha1sums = 3d43c9d56347f248732b1d72f29c7bf799f03864
+
+pkgname = ddd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88b9c4ce2a0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=ddd
+pkgver=3.3.12
+pkgrel=10
+pkgdesc="A graphical front-end for command-line debuggers such as GDB, JDB, pydb, perl debugger..."
+arch=('x86_64')
+url="http://www.gnu.org/software/ddd/"
+license=('GPL3' 'LGPL3')
+depends=('gcc-libs' 'openmotif' 'libxaw')
+optdepends=('gdb: to use the Gnu debugger'
+ 'java-runtime-openjdk: to use the Java debugger'
+ 'pydb: to use the Python debugger'
+ 'perl: to use the Perl debugger')
+source=(http://ftp.gnu.org/gnu/ddd/${pkgname}-${pkgver}.tar.gz{,.sig} ddd-3.3.12-gcc44.patch)
+sha1sums=('b91d2dfb1145af409138bd34517a898341724e56'
+ 'de155d812da6e11e55cc882292bb5c7b30bd31a1'
+ '3d43c9d56347f248732b1d72f29c7bf799f03864')
+validpgpkeys=('4B286694DE99D517AA8DFF2D6656C593E5158D1A')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -p1 -i "${srcdir}/ddd-3.3.12-gcc44.patch"
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ LIBS+="-pthread" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 icons/ddd.xpm "${pkgdir}/usr/share/pixmaps/ddd.xpm"
+}
diff --git a/ddd-3.3.12-gcc44.patch b/ddd-3.3.12-gcc44.patch
new file mode 100644
index 000000000000..2464b2b4a9c4
--- /dev/null
+++ b/ddd-3.3.12-gcc44.patch
@@ -0,0 +1,10 @@
+--- ddd-3.3.12-orig/ddd/strclass.C
++++ ddd-3.3.12/ddd/strclass.C
+@@ -39,6 +39,7 @@
+ #include <limits.h>
+ #include <new>
+ #include <stdlib.h>
++#include <stdio.h>
+
+ void string::error(const char* msg) const
+ {