aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandy Fay2022-07-08 22:19:19 -0600
committerRandy Fay2022-07-08 22:19:19 -0600
commit4090d91c0352c187592d389eb4e9795cc2dbfed2 (patch)
tree1a1b241c92e7ba3fa766e496bc40c90d3f45ea6b
parent65e611ab1d841f078c9b419897be2afecfd3e725 (diff)
downloadaur-4090d91c0352c187592d389eb4e9795cc2dbfed2.tar.gz
Put it back to v1.19.3 where it should have been
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 27 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6c3c4a5c573..0d26da662705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = ddev-edge-bin
- pkgdesc = DDEV-Local: a local web development environment (edge)
- pkgver = 1.19.4
+ pkgdesc = DDEV-Local: a local PHP development environment system (edge channel)
+ pkgver = v1.19.3
pkgrel = 1
url = https://github.com/drud/ddev
- license = Apache 2
- conflicts = ddev
- provides = ddev
- arch = aarch64
- source_aarch64 = https://github.com/rfay/ddev/releases/download/v1.19.4/ddev_linux-arm64.v1.19.4.tar.gz
- sha256sums_aarch64 = 0384f2d86641032893d2bdcce0252728a0555a5145130fbe43e59a71ecd95809
arch = x86_64
- source_x86_64 = https://github.com/rfay/ddev/releases/download/v1.19.4/ddev_linux-amd64.v1.19.4.tar.gz
- sha256sums_x86_64 = bee671995e835ff8d0bd274472a2aa45064e062fdb9fea0e0745f8c061db7654
-
+ license = Apache
+ depends = docker
+ depends = docker-compose
+ optdepends = bash-completion: subcommand completion support
+ provides = ddev
+ conflicts = ddev
+ source = https://github.com/drud/ddev/releases/download/v1.19.3/ddev_linux-amd64.v1.19.3.tar.gz
+ sha256sums = a22671013ab814ff73954bed4ead258dcda98182e1c4d313784305b81cf34eff
+
pkgname = ddev-edge-bin
+
diff --git a/PKGBUILD b/PKGBUILD
index 8272472dabe7..459150ce6905 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,20 @@
-# This file was generated by GoReleaser. DO NOT EDIT.
-# Maintainer: Randy Fay <randy at randyfay.com>
-
-pkgname='ddev-edge-bin'
-pkgver=1.19.4
+pkgname="ddev-edge-bin"
+pkgver=v1.19.3
pkgrel=1
-pkgdesc='DDEV-Local: a local web development environment (edge)'
+pkgdesc='DDEV-Local: a local PHP development environment system (edge channel)'
+arch=('x86_64')
url='https://github.com/drud/ddev'
-arch=('aarch64' 'x86_64')
-license=('Apache 2')
-provides=('ddev')
-conflicts=('ddev')
-
-source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/rfay/ddev/releases/download/v1.19.4/ddev_linux-arm64.v1.19.4.tar.gz")
-sha256sums_aarch64=('0384f2d86641032893d2bdcce0252728a0555a5145130fbe43e59a71ecd95809')
-
-source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/rfay/ddev/releases/download/v1.19.4/ddev_linux-amd64.v1.19.4.tar.gz")
-sha256sums_x86_64=('bee671995e835ff8d0bd274472a2aa45064e062fdb9fea0e0745f8c061db7654')
+license=('Apache')
+provides=("ddev")
+conflicts=("ddev")
+depends=('docker' 'docker-compose')
+optdepends=('bash-completion: subcommand completion support')
+source=("https://github.com/drud/ddev/releases/download/v1.19.3/ddev_linux-amd64.v1.19.3.tar.gz")
+sha256sums=("a22671013ab814ff73954bed4ead258dcda98182e1c4d313784305b81cf34eff")
package() {
- # bin
- install -Dm755 "./ddev" "${pkgdir}/usr/bin/ddev"
- install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/ddev/LICENSE"
-
- # completions
- mkdir -p "${pkgdir}/usr/share/bash-completion/completions/"
- mkdir -p "${pkgdir}/usr/share/zsh/site-functions/"
- mkdir -p "${pkgdir}/usr/share/fish/vendor_completions.d/"
- install -Dm644 "./ddev_bash_completion.sh" "${pkgdir}/usr/share/bash-completion/completions/ddev"
- install -Dm644 "./ddev_zsh_completion.sh" "${pkgdir}/usr/share/zsh/site-functions/_ddev"
- install -Dm644 "./ddev_fish_completion.sh" "${pkgdir}/usr/share/fish/vendor_completions.d/ddev.fish"
+ install -D -m 0755 ddev "$pkgdir/usr/bin/ddev"
+ install -D -m 0644 ddev_bash_completion.sh "$pkgdir/usr/share/bash-completion/completions/ddev"
+ install -D -m 0644 ddev_zsh_completion.sh "$pkgdir/usr/share/zsh/site-functions/_ddev"
+ install -D -m 0644 ddev_fish_completion.sh "$pkgdir/usr/share/fish/vendor_completions.d/ddev.fish"
}