aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Kaland2020-04-20 17:58:37 +0200
committerKevin Kaland2020-04-20 17:58:37 +0200
commitda4f0e6e36dc606c261da7d2fa0752bca2bcbd88 (patch)
treedbc33870f4ad85829d5ae63b80e18b3380474552
downloadaur-da4f0e6e36dc606c261da7d2fa0752bca2bcbd88.tar.gz
Release version v1.14.0-rc2.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
-rw-r--r--README.md40
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1258e046acfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ddev-edge-bin
+ pkgdesc = DDEV-Local: a local PHP development environment system (edge release)
+ pkgver = 1.14.0_rc2
+ pkgrel = 1
+ url = https://github.com/drud/ddev
+ arch = x86_64
+ license = Apache
+ depends = docker
+ depends = docker-compose
+ optdepends = bash-completion: subcommand completion support
+ provides = ddev-edge
+ conflicts = ddev-edge
+ conflicts = ddev-bin
+ source = https://github.com/drud/ddev/releases/download/v1.14.0-rc2/ddev_linux.v1.14.0-rc2.tar.gz
+ sha256sums = 14038228baaa025cc58376d3ba1638154ac67ba830eeefaf49121ad5ea9a42ef
+
+pkgname = ddev-edge-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9917406ea45d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.xz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b315af31a6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kevin Kaland < kevin at wizone dot solutions >
+
+_name="ddev"
+_version="1.14.0"
+_versionsuffix="rc2"
+_downloadver="$_version"-"$_versionsuffix"
+pkgname="$_name-edge-bin"
+pkgver="$_version"_"$_versionsuffix"
+pkgrel=1
+pkgdesc='DDEV-Local: a local PHP development environment system (edge release)'
+arch=('x86_64')
+url='https://github.com/drud/ddev'
+license=('Apache')
+provides=("$_name")
+depends=('docker' 'docker-compose')
+optdepends=('bash-completion: subcommand completion support')
+source=("https://github.com/drud/ddev/releases/download/v$_downloadver/ddev_linux.v$_downloadver.tar.gz")
+sha256sums=("14038228baaa025cc58376d3ba1638154ac67ba830eeefaf49121ad5ea9a42ef")
+
+package() {
+ install -D -m 0755 ddev "$pkgdir/usr/bin/ddev"
+ install -D -m 0755 ddev_bash_completion.sh "$pkgdir/usr/share/bash-completion/completions/ddev"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..090a13579823
--- /dev/null
+++ b/README.md
@@ -0,0 +1,40 @@
+# New ddev release:
+
+* Bump `pkgver` key in `PKGBUILD`
+* Update the `sha256sums` key appropriately
+* Do _not_ bump `pkgrel` key
+* `makepkg --printsrcinfo > .SRCINFO`
+* Test that the package builds properly: `makepkg -s`
+* If everything is good, `git add .SRCINFO PKGBUILD && git commit -m "Bumping ddev-bin version"`
+* `git push`
+
+# Using Docker to perform the release
+
+If you're not running Arch as your main OS, you can perform the `makepkg` steps
+inside of a docker container like so:
+
+```bash
+docker run --mount type=bind,source=$(pwd),target=/tmp/ddev-bin --workdir=/tmp/ddev-bin -it archlinux:latest bash
+```
+
+Once the container comes up, you'll need to install a couple of things:
+
+```bash
+pacman -Sy sudo binutils fakeroot docker docker-compose
+```
+
+You need sudo because `makepkg` refuses to run as root. `binutils` and `fakeroot`
+are dependencies of `makepkg` that are somehow not installed in the Docker image
+by default. `docker` and `docker-compose` are needed as dependencies of the `ddev-bin`
+package, but you don't need to do anything special with them other than install
+the packages so that `makepkg` doesn't complain.
+
+You'll also need to set a password for `nobody` because `fakeroot` uses `sudo`:
+
+```bash
+passwd nobody
+```
+
+When you run `makepkg -s`, you'll be prompted for this password.
+
+Finally, you'll need to preface the `makepkg` steps with `sudo -u nobody`.