summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Schulte2019-07-25 12:48:48 -0400
committerEric Schulte2019-07-25 12:48:48 -0400
commit9e2b961d97a6999a6a1c6377ed523aa4b72d3bd0 (patch)
treea703e07b050c8a9d67eaa46a33a9a02448b1c8b0
parent3e570618164ae66384750153e762021d47590df1 (diff)
downloadaur-9e2b961d97a6999a6a1c6377ed523aa4b72d3bd0.tar.gz
Stable souffle and re-enable compiler opts
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 865e82c07074..8ccf0c21d346 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Eric Schulte <eschulte@grammatech.com>
_srcname=ddisasm
pkgname=ddisasm-git
-pkgver=v0.1.0.r2.g71cd81b
+pkgver=v0.1.1.r118.g29ab093
pkgrel=1
pkgdesc="A fast and accurate disassembler"
arch=('x86_64')
@@ -10,7 +10,7 @@ url="https://github.com/grammatech/ddisasm"
license=('aGPLv3')
optdepends=('boost: build against system boost')
depends=('capstone')
-makedepends=('git' 'cmake' 'souffle-git' 'mcpp' 'gtirb' 'gtirb-pprinter')
+makedepends=('git' 'cmake' 'souffle' 'mcpp' 'gtirb' 'gtirb-pprinter')
provides=('ddisasm')
source=('git://github.com/grammatech/ddisasm.git')
sha512sums=('SKIP')
@@ -30,7 +30,8 @@ build() {
# CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
# CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
# LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
- CFLAGS="" CXXFLAGS="" LDFLAGS="" cmake . -Bbuild $FLAGS
+ # CFLAGS="" CXXFLAGS="" LDFLAGS="" cmake . -Bbuild $FLAGS
+ cmake . -Bbuild
make -C build
}