summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyozuki2020-05-30 10:11:22 +0200
committerRyozuki2020-05-30 10:11:22 +0200
commit4e4753a7d9ad06331ccc1380d8f68f0940cd2a2a (patch)
treec2d85b915590935d3732e7af4a4384e9b0f4acff
parentafae263acc2de53a07f153338f2ff7ce93d12e17 (diff)
downloadaur-4e4753a7d9ad06331ccc1380d8f68f0940cd2a2a.tar.gz
Update to 13.2.1 and enable UPNP
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81e0306074a7..34bab58bb53c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddnet
pkgdesc = A Teeworlds modification with a unique cooperative gameplay.
- pkgver = 13.2
+ pkgver = 13.2.1
pkgrel = 1
url = https://ddnet.tw
arch = x86_64
@@ -19,13 +19,14 @@ pkgbase = ddnet
depends = pnglite
depends = ffmpeg
depends = libnotify
+ depends = miniupnpc
optdepends = ddnet-skins: A collection with more than 700 custom tee skins.
optdepends = ddnet-maps-git: All the maps used on the official DDNet Servers.
- source = https://ddnet.tw/downloads/DDNet-13.2.tar.xz
+ source = https://ddnet.tw/downloads/DDNet-13.2.1.tar.xz
source = ddnet-server.service
source = ddnet-sysusers.conf
source = ddnet-tmpfiles.conf
- sha256sums = bc542153012f71501f3527dc2f50c880616774b0722fc241646d2f0e38e3e298
+ sha256sums = 49ebc6a91ab20e5acdc51fd3fcc4bb35ebda64da6ec4999a04c6655dff9af8c5
sha256sums = 9377a9d7c87abae166c8fa98cd79a61c74482f80f80bc930ae043349e9a84965
sha256sums = 70034f237270b38bf312238a26cfd322e212ca5714bfea4ae91e80c639ce8738
sha256sums = 043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369
diff --git a/PKGBUILD b/PKGBUILD
index b19856626b86..42aba4b2ee63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Maintainer: Ryozuki <ryo@ryozuki.xyz>
pkgname=ddnet
-pkgver=13.2
+pkgver=13.2.1
pkgrel=1
pkgdesc="A Teeworlds modification with a unique cooperative gameplay."
arch=('x86_64')
url="https://ddnet.tw"
license=('custom:BSD' 'CCPL:by-nc-sa')
-depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify')
+depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify' 'miniupnpc')
makedepends=('cmake' 'ninja' 'python')
checkdepends=('gtest')
optdepends=('ddnet-skins: A collection with more than 700 custom tee skins.'
'ddnet-maps-git: All the maps used on the official DDNet Servers.')
source=("https://ddnet.tw/downloads/DDNet-$pkgver.tar.xz"
"ddnet-server.service" "ddnet-sysusers.conf" "ddnet-tmpfiles.conf")
-sha256sums=('bc542153012f71501f3527dc2f50c880616774b0722fc241646d2f0e38e3e298'
+sha256sums=('49ebc6a91ab20e5acdc51fd3fcc4bb35ebda64da6ec4999a04c6655dff9af8c5'
'9377a9d7c87abae166c8fa98cd79a61c74482f80f80bc930ae043349e9a84965'
'70034f237270b38bf312238a26cfd322e212ca5714bfea4ae91e80c639ce8738'
'043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369')
@@ -38,6 +38,7 @@ build() {
-DAUTOUPDATE=OFF \
-DANTIBOT=ON \
-DVIDEORECORDER=ON \
+ -DUPNP=ON \
-GNinja \
$_mysql_opt
ninja