summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2021-06-12 18:58:01 -0300
committerRafael Fontenelle2021-06-12 19:08:13 -0300
commit03807808411ad4e2edfd1440c5da0499fa45ce19 (patch)
tree4cdf13d290c1575b5a266d6706fc1f17678a0a17
parent5896df43d2d4ca93d0df038568fe53f76ed6df30 (diff)
downloadaur-03807808411ad4e2edfd1440c5da0499fa45ce19.tar.gz
Update to 15.5.1 and apply fixes
Changes in the commit: - use current proper checkdepends "gmock" - remove sdl2 dependency because ffmpeg already satisfies it - enable MySQL support by default, removing now unused mysql-connector-c++ and boost dependencies - update description in optdepends - change pkgver to use g++ solution, instead of bash's. fun! - cosmetic changes in packaging function - DDNet now install autoexec_server, so make sure it doesn't conflict with ddnet-maps-git's autoexec_server.cfg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD39
2 files changed, 24 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c8792e5f992..2c8085e68bdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = ddnet-git
pkgdesc = A Teeworlds modification with a unique cooperative gameplay.
- pkgver = 14.3.2.r0.g048bb992b
+ pkgver = 15.5.1.r4.g32523b1ea
pkgrel = 1
url = https://ddnet.tw
arch = x86_64
license = custom:BSD
license = CCPL:by-nc-sa
- checkdepends = gtest
+ checkdepends = gmock
makedepends = git
makedepends = cmake
makedepends = ninja
makedepends = python
- depends = sdl2
depends = freetype2
depends = opusfile
depends = curl
@@ -22,10 +21,12 @@ pkgbase = ddnet-git
depends = libnotify
depends = miniupnpc
depends = sqlite
- optdepends = ddnet-skins: A collection with more than 700 custom tee skins.
+ depends = mariadb-libs
+ optdepends = ddnet-skins: A collection with more than 500 custom tee skins.
optdepends = ddnet-maps-git: All the maps used on the official DDNet Servers.
provides = ddnet
conflicts = ddnet
+ backup = usr/share/ddnet/data/autoexec_server.cfg
source = git+https://github.com/ddnet/ddnet
source = ddnet-server.service
source = ddnet-sysusers.conf
@@ -36,4 +37,3 @@ pkgbase = ddnet-git
sha256sums = 043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369
pkgname = ddnet-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f8db9e3366f8..8b4d3c5ce630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Maintainer: Edgar Luque <git@edgarluque.com>
pkgname=ddnet-git
-pkgver=14.3.2.r0.g048bb992b
+pkgver=15.5.1.r4.g32523b1ea
pkgrel=1
pkgdesc="A Teeworlds modification with a unique cooperative gameplay."
arch=('x86_64')
url="https://ddnet.tw"
license=('custom:BSD' 'CCPL:by-nc-sa')
-depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify' 'miniupnpc' 'sqlite')
+depends=('freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify' 'miniupnpc' 'sqlite' 'mariadb-libs')
makedepends=('git' 'cmake' 'ninja' 'python')
-checkdepends=('gtest')
-optdepends=('ddnet-skins: A collection with more than 700 custom tee skins.'
+checkdepends=('gmock')
+optdepends=('ddnet-skins: A collection with more than 500 custom tee skins.'
'ddnet-maps-git: All the maps used on the official DDNet Servers.')
provides=('ddnet')
conflicts=('ddnet')
+backup=('usr/share/ddnet/data/autoexec_server.cfg')
source=("git+https://github.com/ddnet/ddnet"
'ddnet-server.service' 'ddnet-sysusers.conf' 'ddnet-tmpfiles.conf')
sha256sums=('SKIP'
@@ -22,18 +23,13 @@ sha256sums=('SKIP'
'70034f237270b38bf312238a26cfd322e212ca5714bfea4ae91e80c639ce8738'
'043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369')
-# Set 1 to enable MySQL support and add dependencies
-_enable_mysql=0
-
-if [ $_enable_mysql -eq 1 ]; then
- depends+=('mysql-connector-c++')
- makedepends+=('boost')
- _mysql_opt="-DMYSQL=ON"
-fi
-
pkgver() {
cd ddnet
- v=$(grep "GAME_RELEASE_VERSION" src/game/version.h | cut -d\" -f2)
+ v=$(echo '#include "src/game/version.h"
+ #include <iostream>
+ int main() {
+ std::cout << GAME_RELEASE_VERSION << std::endl;
+ }' | g++ -xc++ - && ./a.out)
_commit=$(git log --pretty=oneline | grep "Version $v" | cut -d' ' -f1)
r=$(git log $_commit..HEAD --pretty=oneline | wc -l)
h=$(git rev-parse --short HEAD)
@@ -50,8 +46,8 @@ build() {
-DANTIBOT=ON \
-DVIDEORECORDER=ON \
-DUPNP=ON \
- -GNinja \
- $_mysql_opt
+ -DMYSQL=ON \
+ -GNinja
ninja
}
@@ -61,8 +57,11 @@ check() {
package() {
DESTDIR="$pkgdir" ninja install -C build
- install -vDm644 ddnet/license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
- install -vDm644 ddnet-server.service "$pkgdir/usr/lib/systemd/system/ddnet-server.service"
- install -vDm644 "$srcdir/ddnet-sysusers.conf" "$pkgdir/usr/lib/sysusers.d/ddnet.conf"
- install -vDm644 "$srcdir/ddnet-tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/ddnet.conf"
+ install -vDm644 "$srcdir/ddnet/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ install -vDm644 "$srcdir/ddnet-server.service" "$pkgdir/usr/lib/systemd/system/ddnet-server.service"
+ install -vDm644 "$srcdir/ddnet-sysusers.conf" "$pkgdir/usr/lib/sysusers.d/ddnet.conf"
+ install -vDm644 "$srcdir/ddnet-tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/ddnet.conf"
+ sed -i "$pkgdir/usr/share/ddnet/data/autoexec_server.cfg" \
+ -e '/sv_test_cmds/s/1/0/' \
+ -e 's/myServerconfig.cfg/autoexec_server_maps.cfg/'
}