summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2020-06-27 12:48:15 -0300
committerRafael Fontenelle2020-06-27 12:48:15 -0300
commit3d503c2a3832f8b497dabb8cdaf4a336a58dcec5 (patch)
treea8f9a092331cb817545e05b1cf9341eef782fdd9
parentfcf1d41df0efcea5f051a966e4515b5b669b2e0f (diff)
downloadaur-3d503c2a3832f8b497dabb8cdaf4a336a58dcec5.tar.gz
Sync with ddnet package
- Avoid cleaning up on every build (makepkg's -C flag can be used to acomplish this task) - Add and enable miniupnpc
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ca72077900d..1aee28a574a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddnet-git
pkgdesc = A Teeworlds modification with a unique cooperative gameplay.
- pkgver = 13.0.2.r18.g602bd2731
+ pkgver = 14.0.2.r3.g3ada0111b
pkgrel = 1
url = https://ddnet.tw
arch = x86_64
@@ -20,8 +20,9 @@ pkgbase = ddnet-git
depends = pnglite
depends = ffmpeg
depends = libnotify
+ depends = miniupnpc
optdepends = ddnet-skins: A collection with more than 700 custom tee skins.
- optdepends = ddnet-maps-git: All the maps used on the official DDNet Servers
+ optdepends = ddnet-maps-git: All the maps used on the official DDNet Servers.
provides = ddnet
conflicts = ddnet
source = git+https://github.com/ddnet/ddnet
diff --git a/PKGBUILD b/PKGBUILD
index 92508ef28b7b..229b589e0f92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Maintainer: Ryozuki <ryo@ryozuki.xyz>
pkgname=ddnet-git
-pkgver=13.0.2.r18.g602bd2731
+pkgver=14.0.2.r3.g3ada0111b
pkgrel=1
pkgdesc="A Teeworlds modification with a unique cooperative gameplay."
arch=('x86_64')
url="https://ddnet.tw"
license=('custom:BSD' 'CCPL:by-nc-sa')
-depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify')
+depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify' 'miniupnpc')
makedepends=('git' 'cmake' 'ninja' 'python')
checkdepends=('gtest')
optdepends=('ddnet-skins: A collection with more than 700 custom tee skins.'
- 'ddnet-maps-git: All the maps used on the official DDNet Servers')
+ 'ddnet-maps-git: All the maps used on the official DDNet Servers.')
provides=('ddnet')
conflicts=('ddnet')
source=("git+https://github.com/ddnet/ddnet"
@@ -41,7 +41,7 @@ pkgver() {
}
build() {
- [ -d build ] && rm -rf build; mkdir build
+ mkdir -p build
cd build
cmake ../ddnet \
-DCMAKE_BUILD_TYPE=Release \
@@ -49,6 +49,7 @@ build() {
-DAUTOUPDATE=OFF \
-DANTIBOT=ON \
-DVIDEORECORDER=ON \
+ -DUPNP=ON \
-GNinja \
$_mysql_opt
ninja