summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2020-10-12 16:50:48 -0300
committerRafael Fontenelle2020-10-12 16:51:38 -0300
commit89a418e36ea78ef6d59ab3e6bdadcb7fc3208e27 (patch)
tree8fd66061aab2e16c717a575f01266c97bed74e9e
parent022de57cbea7eb0a0a132d94b132f41a4a85aceb (diff)
downloadaur-89a418e36ea78ef6d59ab3e6bdadcb7fc3208e27.tar.gz
Update to r1319.g9a8bd3bf
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD39
2 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad750126f9a2..9fb202ea3ac3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddnet-maps-git
pkgdesc = All released maps with configs for DDraceNetwork server
- pkgver = r1289.gc3ac2521
+ pkgver = r1319.g9a8bd3bf
pkgrel = 1
url = https://ddnet.tw
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 82bd1972b367..dbd289179873 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=ddnet-maps
pkgname=$_name-git
-pkgver=r1289.gc3ac2521
+pkgver=r1319.g9a8bd3bf
pkgrel=1
pkgdesc="All released maps with configs for DDraceNetwork server"
arch=(any)
@@ -32,37 +32,26 @@ prepare() {
package() {
cd $_name
-
+
_datadir="$pkgdir/usr/share/ddnet/data"
- install -d -m755 $_datadir/types/
-
+ install -d -m755 $_datadir/{maps,types}
+
install -m644 autoexec_server.cfg $_datadir
install -m644 reset.cfg $_datadir
install -m644 storage.cfg $_datadir
-
+
# Disable test flag
sed '/sv_test_cmds/s/1/0/' -i $_datadir/autoexec_server.cfg
-
- # Append a '#' to line of the map type you DO NOT want to be installed
- cp -a types/brutal $_datadir/types/
- cp -a types/ddmax $_datadir/types/
- cp -a types/dummy $_datadir/types/
- cp -a types/insane $_datadir/types/
- cp -a types/moderate $_datadir/types/
- cp -a types/novice $_datadir/types/
- cp -a types/oldschool $_datadir/types/
- cp -a types/race $_datadir/types/
- cp -a types/solo $_datadir/types/
- # Also make the maps available for the client
- install -d -m755 $_datadir/maps/
- cd $_datadir/maps/
- for type in $(ls $_datadir/types/); do
- ln -rs $_datadir/types/$type/maps/* .
+ _types="brutal ddmax dummy insane moderate novice oldschool race solo"
+ for type in $_types; do
+ cp -a types/$type $_datadir/types/
+ ln -rs $_datadir/types/$type/maps/* $_datadir/maps/
done
- # Avoid file conflicts as they are already provided in DDNet package
- rm "$_datadir/maps/Goo!.map" \
- "$_datadir/maps/Kobra 4.map" \
- "$_datadir/maps/Gold Mine.map"
+ # Avoid file conflicts of maps already provided in the DDNet package
+ rm -f "$_datadir/maps/Gold Mine.map" \
+ "$_datadir/maps/LearnToPlay.map" \
+ "$_datadir/maps/Sunny Side Up.map" \
+ "$_datadir/maps/Tsunami.map"
}