summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClansty2022-03-17 17:43:22 +0800
committerClansty2022-03-17 17:43:22 +0800
commit4841071a51ccad82eb6d9c5090238170faeeda70 (patch)
tree763e1947f5fe1a31fe7b2586d16bc4e8e3d68146
downloadaur-4841071a51ccad82eb6d9c5090238170faeeda70.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD24
-rw-r--r--ddns-go.service12
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..953700622e37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ddns-go-bin
+ pkgdesc = 简单好用的DDNS。自动更新域名解析到公网IP(支持阿里云、腾讯云dnspod、Cloudflare、华为云)
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = https://github.com/Icalingua/Icalingua
+ arch = aarch64
+ arch = x86_64
+ arch = i686
+ license = MIT
+ provides = ddns-go
+ conflicts = ddns-go
+ source = ddns-go.service
+ sha256sums = c264ee5afaee8abed884cdd167f2e3281e08c3d74778790263163c114cd650d5
+ source_aarch64 = https://github.com/jeessy2/ddns-go/releases/download/v3.5.0/ddns-go_3.5.0_Linux_arm64.tar.gz
+ sha256sums_aarch64 = 239d331e021ac602c86d5965fca5c3b40346d513db18bc7414a9f7898e161c1c
+ source_x86_64 = https://github.com/jeessy2/ddns-go/releases/download/v3.5.0/ddns-go_3.5.0_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = af2138691414c25fd4d4859c7a4d5c5ac661c611345655a1879e7fc2cb08a29a
+ source_i686 = https://github.com/jeessy2/ddns-go/releases/download/v3.5.0/ddns-go_3.5.0_Linux_i386.tar.gz
+ sha256sums_i686 = 0e1d62f50034d0cbe5009225d2211a41f784578b3decb26c1c4fb0f7810c6ce2
+
+pkgname = ddns-go-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8ab34310c28d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.zst
+*.asar
+*.xz
+*.tar
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c0115c0663b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_pkgname=ddns-go
+pkgname=${_pkgname}-bin
+pkgver=3.5.0
+pkgrel=1
+pkgdesc='简单好用的DDNS。自动更新域名解析到公网IP(支持阿里云、腾讯云dnspod、Cloudflare、华为云)'
+license=('MIT')
+arch=('aarch64' 'x86_64' 'i686')
+url="https://github.com/Icalingua/Icalingua"
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=(${_pkgname}.service)
+source_x86_64=("https://github.com/jeessy2/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_x86_64.tar.gz")
+source_aarch64=("https://github.com/jeessy2/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_arm64.tar.gz")
+source_i686=("https://github.com/jeessy2/${_pkgname}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_Linux_i386.tar.gz")
+
+package() {
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${_pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
+}
+sha256sums=('c264ee5afaee8abed884cdd167f2e3281e08c3d74778790263163c114cd650d5')
+sha256sums_aarch64=('239d331e021ac602c86d5965fca5c3b40346d513db18bc7414a9f7898e161c1c')
+sha256sums_x86_64=('af2138691414c25fd4d4859c7a4d5c5ac661c611345655a1879e7fc2cb08a29a')
+sha256sums_i686=('0e1d62f50034d0cbe5009225d2211a41f784578b3decb26c1c4fb0f7810c6ce2')
diff --git a/ddns-go.service b/ddns-go.service
new file mode 100644
index 000000000000..9b4afbc9c4c5
--- /dev/null
+++ b/ddns-go.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=简单好用的DDNS。自动更新域名解析到公网IP(支持阿里云、腾讯云dnspod、Cloudflare、华为云)
+
+[Service]
+StartLimitInterval=5
+StartLimitBurst=10
+ExecStart=/usr/bin/ddns-go "-l" ":9876" "-f" "300" "-c" "/etc/ddns-go.yaml"
+Restart=always
+RestartSec=120
+
+[Install]
+WantedBy=multi-user.target