summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat Bakarov2015-06-22 11:26:40 +0600
committerAskhat Bakarov2015-06-22 11:26:40 +0600
commitc69330624cc0633c3b8859016b7557a9288a965c (patch)
tree5c332c7a48a95b4b2fdf2b56e5879ccd0617d7bb
downloadaur-c69330624cc0633c3b8859016b7557a9288a965c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..546f8aadeb5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ddrescueview-bin
+ pkgdesc = Graphical viewer for GNU ddrescue log files
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://sourceforge.net/projects/ddrescueview
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = gtk2
+ provides = ddrescueview
+ conflicts = ddrescueview
+ source = http://downloads.sourceforge.net/project/ddrescueview/Releases/v0.3/Linux-/ddrescueview-linux--0.3.zip
+
+pkgname = ddrescueview-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ee051a7119e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer:
+
+pkgname=ddrescueview-bin
+_pkgname=ddrescueview
+pkgver=0.3
+pkgrel=1
+pkgdesc="Graphical viewer for GNU ddrescue log files"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/ddrescueview"
+license=('GPL')
+provides=(ddrescueview)
+conflicts=(ddrescueview)
+depends=('gtk2')
+makedepends=('unzip')
+
+case ${CARCH} in
+ i686)
+ _bldarch='i386'
+ sha1sums=('c46ce32492105be4740e6173dbb2592eead1f32c')
+ ;;
+ x86_64)
+ _bldarch='x86_64'
+ sha1sums=('f8edc6b6cfe2828d7e0832a6b3d54985d6ea7a19')
+ ;;
+esac
+
+source=(http://downloads.sourceforge.net/project/${_pkgname}/Releases/v${pkgver}/Linux-${_bldarch}/${_pkgname}-linux-${_bldarch}-${pkgver}.zip)
+
+package() {
+
+ install -D -m 755 "${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}"
+
+}