summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStykers2019-04-13 12:52:06 +0900
committerStykers2019-04-13 12:52:06 +0900
commit47b2a592e1ace621df772cddaa81527271aad375 (patch)
tree959d79f02b71d1f54b47d915ae17f4440ee404b6
downloadaur-47b2a592e1ace621df772cddaa81527271aad375.tar.gz
added stuff
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
-rw-r--r--ddshttpd.install11
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..152e69df724d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ttf-electroharmonix
+ pkgdesc = An old and weird http server that uses only dd and sh.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.youtube.com/channel/UCpDvds5zXZVcQAxKaVA7xwA
+ install = ddshttpd.install
+ arch = any
+ license = GPL
+ depends = sh
+ source = https://git.syskiller.io/Stykers/fonts/raw/master/ddshttpd.sh
+ md5sums = 1bc4cf0b6f3045a05cad9e32fe35a435
+
+pkgname = ddshttpd
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ca361f58935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Stykers <stykers at stykers dot moe>
+
+pkgname=ddshttpd
+pkgver=1.0
+pkgrel=3
+pkgdesc="An old and weird http server that uses only dd and sh."
+arch=('any')
+url="https://git.syskiller.io/Stykers/fonts/raw/master/ddshttpd.sh"
+license=('GPL')
+depends=('sh')
+source=('https://git.syskiller.io/Stykers/fonts/raw/master/ddshttpd.sh')
+install=${pkgname}.install
+md5sums=('1bc4cf0b6f3045a05cad9e32fe35a435')
+
+package() {
+ install -Dm755 ${srcdir}/ddshttpd.sh ${pkgdir}/usr/bin/ddshttpd
+ }
diff --git a/ddshttpd.install b/ddshttpd.install
new file mode 100644
index 000000000000..e2bb68ef8fa7
--- /dev/null
+++ b/ddshttpd.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo -n "Thank you for installing my package!"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}