summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortioguda2020-01-10 07:22:52 -0300
committertioguda2020-01-10 07:22:52 -0300
commit659bfca0fc2f91f8f030ee4eb1610cef6a5f98e3 (patch)
tree934c792c22f922b05a2bb81c5a1a1d6dc1c1af69
parent6f2a9e0ea8debc95340dd6e6f8a0ce5b9cde63b6 (diff)
downloadaur-659bfca0fc2f91f8f030ee4eb1610cef6a5f98e3.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
-rw-r--r--fix.patch32
3 files changed, 52 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b98246222a9e..b23b49e119fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = ddutility-bin-pt-br
pkgdesc = Gravar e fazer backup dos arquivos IMG e ISO do sistema operacional no cartão de memória ou no disco
pkgver = 1.5
- pkgrel = 1
+ pkgrel = 2
url = https://www.thefanclub.co.za/how-to/dd-utility-write-and-backup-operating-system-img-and-iso-files-memory-card-or-disk
arch = any
license = custom
depends = lsof
depends = udevil
- depends = gksu
+ depends = zensu
depends = xz
depends = coreutils
depends = bash
@@ -18,8 +18,10 @@ pkgbase = ddutility-bin-pt-br
conflicts = ddutility-bin
source = https://raw.githubusercontent.com/thefanclub/dd-utility/master/DEB/ddutility_1.5_all.deb
source = translation_pt-br.patch
+ source = fix.patch
sha256sums = 49417d46f41550ef1346670269f7d08be499ef4127fca99d762dfb90942ce445
sha256sums = 8063e165853a79c342e472e973a25c70a2de82071277f221bc82c0b4f73b06fa
+ sha256sums = 8e68e59e666e4e57939fe9579d83d7cfb6c67585d754a1c8455f8623465accba
pkgname = ddutility-bin-pt-br
diff --git a/PKGBUILD b/PKGBUILD
index 5db0499a646f..d3f6e2fe4f0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,33 @@
_pkgname=ddutility
pkgname=ddutility-bin-pt-br
pkgver=1.5
-pkgrel=1
+pkgrel=2
pkgdesc="Gravar e fazer backup dos arquivos IMG e ISO do sistema operacional no cartão de memória ou no disco"
arch=('any')
license=('custom')
url="https://www.thefanclub.co.za/how-to/dd-utility-write-and-backup-operating-system-img-and-iso-files-memory-card-or-disk"
-depends=('lsof' 'udevil' 'gksu' 'xz' 'coreutils' 'bash' 'gzip' 'zip' 'zenity')
+depends=('lsof' 'udevil' 'zensu' 'xz' 'coreutils' 'bash' 'gzip' 'zip' 'zenity')
conflicts=('ddutility-bin')
provides=('ddutility')
source=("https://raw.githubusercontent.com/thefanclub/dd-utility/master/DEB/${_pkgname}_${pkgver}_all.deb"
- 'translation_pt-br.patch')
+ 'translation_pt-br.patch'
+ 'fix.patch')
sha256sums=('49417d46f41550ef1346670269f7d08be499ef4127fca99d762dfb90942ce445'
- '8063e165853a79c342e472e973a25c70a2de82071277f221bc82c0b4f73b06fa')
+ '8063e165853a79c342e472e973a25c70a2de82071277f221bc82c0b4f73b06fa'
+ '8e68e59e666e4e57939fe9579d83d7cfb6c67585d754a1c8455f8623465accba')
prepare() {
- tar -xJf data.tar.xz
- patch -p1 -i ./translation_pt-br.patch
+ tar -xJf data.tar.xz
+ patch -p1 -i ./translation_pt-br.patch
+ patch -p1 -i ./fix.patch
}
package_ddutility-bin-pt-br() {
- cd "$srcdir"
- # dump usr files to /usr
- mv usr "$pkgdir"
- # dump opt files to /opt
- mv opt "$pkgdir"
+ cd "$srcdir"
+ # dump usr files to /usr
+ mv usr "$pkgdir"
+ # dump opt files to /opt
+ mv opt "$pkgdir"
+
+ install -Dm644 "${pkgdir}/usr/share/doc/ddutility/copyright" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..60bdff2d05a8
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,32 @@
+From 5fe69d9c8f2a7499e1b9c8c42e003490cf76c38d Mon Sep 17 00:00:00 2001
+From: tioguda <guda.flavio@gmail.com>
+Date: Thu, 9 Jan 2020 05:10:51 -0300
+Subject: Fix
+
+
+diff --git a/usr/share/applications/ddutility.desktop b/usr/share/applications/ddutility.desktop
+index 0ceca5f..1d225ce 100755
+--- a/usr/share/applications/ddutility.desktop
++++ b/usr/share/applications/ddutility.desktop
+@@ -6,7 +6,7 @@ GenericName=dd Utility
+ X-GNOME-FullName=dd Utility
+ Comment=Write and Backup Operating System IMG and ISO files on Memory Card
+
+-Exec=gksudo /bin/bash /opt/thefanclub/ddutility/ddutility.sh %U
++Exec=gksu /bin/bash /opt/thefanclub/ddutility/ddutility.sh %U
+ Terminal=false
+ Path=/opt/thefanclub/ddutility/
+ Icon=/opt/thefanclub/ddutility/ddutility.png
+@@ -18,10 +18,10 @@ X-Ayatana-Desktop-Shortcuts=Backup;Restore
+
+ [Backup Shortcut Group]
+ Name=Backup
+-Exec=gksudo "/bin/bash /opt/thefanclub/ddutility/ddutility.sh --Backup"
++Exec=gksu "/bin/bash /opt/thefanclub/ddutility/ddutility.sh --Backup"
+ TargetEnvironment=Unity
+
+ [Restore Shortcut Group]
+ Name=Restore
+-Exec=gksudo "/bin/bash /opt/thefanclub/ddutility/ddutility.sh --Restore"
++Exec=gksu "/bin/bash /opt/thefanclub/ddutility/ddutility.sh --Restore"
+ TargetEnvironment=Unity