summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-02-27 22:33:46 +0100
committerFabioLolix2022-02-27 22:33:46 +0100
commit7ab3dbddb11d7ce95fd8f626ebb2a0ebbc97165f (patch)
tree5fe255acac6b730e64de2e9a3919e6087f291f40
parentd6ade16714a8401495f539501536c45d047a5b63 (diff)
downloadaur-7ab3dbddb11d7ce95fd8f626ebb2a0ebbc97165f.tar.gz
fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba4eda28159b..c88b81f3ce5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deadbeef
pkgdesc = Modular GTK audio player for GNU/Linux
pkgver = 1.8.8
- pkgrel = 3
+ pkgrel = 4
url = https://deadbeef.sourceforge.io/
arch = x86_64
arch = i686
@@ -31,7 +31,7 @@ pkgbase = deadbeef
makedepends = libzip
makedepends = libsamplerate
makedepends = yasm
- makedepends = ffmpeg
+ makedepends = ffmpeg4.4
makedepends = clang
makedepends = opusfile
makedepends = mpg123
@@ -44,7 +44,7 @@ pkgbase = deadbeef
optdepends = curl: for last.fm, vfs_curl (shoutcast/icecast), artwork plugins
optdepends = dbus: for notification daemon support (OSD current song notifications)
optdepends = faad2: for AAC plugin
- optdepends = ffmpeg: for ffmpeg plugin
+ optdepends = ffmpeg4.4: for ffmpeg plugin
optdepends = flac: for flac plugin
optdepends = imlib2: for artwork plugin
optdepends = libcddb: for cd audio plugin
diff --git a/PKGBUILD b/PKGBUILD
index de613c5a57d1..dfa70037b828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=deadbeef
pkgver=1.8.8
-pkgrel=3
+pkgrel=4
pkgdesc="Modular GTK audio player for GNU/Linux"
arch=(x86_64 i686 pentium4 arm armv6h armv7h aarch64)
url="https://deadbeef.sourceforge.io/"
@@ -12,13 +12,13 @@ license=(GPL2 LGPL2.1 ZLIB)
depends=(gtk3 alsa-lib jansson libdispatch)
makedepends=(libvorbis libmad flac curl imlib2 wavpack libsndfile libcdio libcddb
libx11 faad2 zlib intltool pkgconfig libpulse libzip libsamplerate
- yasm ffmpeg clang opusfile mpg123)
+ yasm ffmpeg4.4 clang opusfile mpg123)
optdepends=('alsa-oss: for OSS output plugin'
'cdparanoia: for cd audio plugin'
'curl: for last.fm, vfs_curl (shoutcast/icecast), artwork plugins'
'dbus: for notification daemon support (OSD current song notifications)'
'faad2: for AAC plugin'
- 'ffmpeg: for ffmpeg plugin'
+ 'ffmpeg4.4: for ffmpeg plugin'
'flac: for flac plugin'
'imlib2: for artwork plugin'
'libcddb: for cd audio plugin'
@@ -42,6 +42,8 @@ optdepends=('alsa-oss: for OSS output plugin'
source=("https://sourceforge.net/projects/deadbeef/files/travis/linux/${pkgver}/deadbeef-${pkgver}.tar.bz2")
sha512sums=('399f0e70eca5e102a9e73ff03199c89c6f28f3e0da96e793316d1af83f00e71f09f6cc81a3fd0b0f0d52fe9e0195a3b9ffb0cf7e7708c3ea7085f33a5ec08b47')
+export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+
build () {
cd "${srcdir}/${pkgname}-${pkgver}"
export CC=clang CXX=clang++