summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSoukyuu2017-10-24 19:55:15 +0200
committerSoukyuu2017-10-24 19:55:15 +0200
commit1163dc25be032079ec679f92c20fc129d895dc78 (patch)
tree6fb1bd9c358752d19e52188364893e6469d721fe
parent179abdd90b293d51b72ef0e882c345ac5bd1a002 (diff)
downloadaur-1163dc25be032079ec679f92c20fc129d895dc78.tar.gz
make gtk2/gtk3/ffmpeg opt+makedepends and don't pre-select any plugins
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5caeed61c08b..b517e148ef81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by makepkg 5.0.0
-# Sun Mar 13 21:09:45 UTC 2016
pkgbase = deadbeef-git
- pkgdesc = Music player based on GTK2 (devel branch)
- pkgver = r6511.88b9879
+ pkgdesc = A GTK+ audio player for GNU/Linux (devel branch)
+ pkgver = r7453.446177f6
pkgrel = 1
url = http://deadbeef.sourceforge.net
install = deadbeef.install
@@ -25,12 +23,15 @@ pkgbase = deadbeef-git
makedepends = libzip
makedepends = wavpack
makedepends = yasm
+ makedepends = ffmpeg
+ makedepends = gtk2
+ makedepends = gtk3
depends = alsa-lib
depends = desktop-file-utils
- depends = gtk2
depends = hicolor-icon-theme
- depends = gtkglext
depends = jansson
+ optdepends = gtk2: for the GTK2 interface
+ optdepends = gtk3: for the GTK3 interface
optdepends = libsamplerate: for dsp_libsrc plugin (resampler)
optdepends = libsm: optional dependency for gtkui session client support
optdepends = libice: optional dependency for gtkui session client support
@@ -54,6 +55,7 @@ pkgbase = deadbeef-git
optdepends = libsidplay: for SID player plugin
optdepends = yasm: required to build assembly portions of ffap plugin
optdepends = libzip: for vfs_zip plugin
+ optdepends = ffmpeg: for ffmpeg plugin
provides = deadbeef
conflicts = deadbeef
options = !libtool
diff --git a/PKGBUILD b/PKGBUILD
index f2780653d38e..97a2b11aaf35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,19 @@
# Maintainer: Soukyuu <chrno-sphered at hotmail dot com>
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
pkgname=deadbeef-git
-pkgver=r6511.88b9879
+pkgver=r7453.446177f6
pkgrel=1
-pkgdesc="Music player based on GTK2 (devel branch)"
+pkgdesc="A GTK+ audio player for GNU/Linux (devel branch)"
url="http://deadbeef.sourceforge.net"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('alsa-lib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'gtkglext' 'jansson')
-makedepends=('curl' 'faad2' 'flac' 'git' 'intltool' 'imlib2' 'libcddb' 'libcdio' 'libmad' 'libpulse' 'libsamplerate' 'libvorbis' 'libx11' 'libzip' 'wavpack' 'yasm')
-optdepends=('libsamplerate: for dsp_libsrc plugin (resampler)'
+depends=('alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme' 'jansson')
+makedepends=('curl' 'faad2' 'flac' 'git' 'intltool' 'imlib2' 'libcddb' 'libcdio' 'libmad' 'libpulse'
+ 'libsamplerate' 'libvorbis' 'libx11' 'libzip' 'wavpack' 'yasm'
+ 'ffmpeg' 'gtk2' 'gtk3')
+optdepends=('gtk2: for the GTK2 interface'
+ 'gtk3: for the GTK3 interface'
+ 'libsamplerate: for dsp_libsrc plugin (resampler)'
'libsm: optional dependency for gtkui session client support'
'libice: optional dependency for gtkui session client support'
'alsa-lib: ALSA support'
@@ -31,7 +35,8 @@ optdepends=('libsamplerate: for dsp_libsrc plugin (resampler)'
'zlib: for Audio Overload plugin (psf, psf2, etc), GME (for vgz)'
'libsidplay: for SID player plugin'
'yasm: required to build assembly portions of ffap plugin'
- 'libzip: for vfs_zip plugin')
+ 'libzip: for vfs_zip plugin'
+ 'ffmpeg: for ffmpeg plugin')
install='deadbeef.install'
options=('!libtool')
conflicts=('deadbeef')
@@ -43,7 +48,7 @@ prepare() {
cd "$srcdir/deadbeef"
./autogen.sh
- ./configure --prefix=/usr --enable-ffmpeg --enable-gtk2 --disable-gtk3
+ ./configure --prefix=/usr
}
build() {