summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToad King2022-07-02 14:41:23 -0500
committerToad King2022-07-02 14:41:23 -0500
commitc2f407f3f4d9905dd4079d4e960936f2b41fbf6e (patch)
tree784933e82d809f321fffb117e672c803a5467c99
downloadaur-c2f407f3f4d9905dd4079d4e960936f2b41fbf6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13ec9c353584
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = deadbeef-mpris2-plugin-git
+ pkgdesc = MPRISv2 plugin for the DeaDBeeF music player (dev branch)
+ pkgver = r168.4da29ba
+ pkgrel = 1
+ url = https://github.com/DeaDBeeF-Player/deadbeef-mpris2-plugin
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glib2
+ depends = deadbeef
+ conflicts = deadbeef-mpris2-plugin
+ options = !libtool
+ source = git+https://github.com/DeaDBeeF-Player/deadbeef-mpris2-plugin.git
+ md5sums = SKIP
+
+pkgname = deadbeef-mpris2-plugin-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e91ecc8f10a1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/deadbeef-mpris2-plugin
+/pkg
+/src
+/*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8720df6a711d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ToadKing <toadking at toadking dot com>
+# Contributor: Peter Lamby <peterlamby@web.de>
+pkgname=deadbeef-mpris2-plugin-git
+pkgver=r168.4da29ba
+pkgrel=1
+pkgdesc="MPRISv2 plugin for the DeaDBeeF music player (dev branch)"
+arch=('i686' 'x86_64')
+url="https://github.com/DeaDBeeF-Player/deadbeef-mpris2-plugin"
+license=('GPL2')
+depends=('glib2' 'deadbeef')
+conflicts=('deadbeef-mpris2-plugin')
+options=('!libtool')
+source=('git+https://github.com/DeaDBeeF-Player/deadbeef-mpris2-plugin.git')
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/deadbeef-mpris2-plugin"
+ autoreconf --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/deadbeef-mpris2-plugin"
+ make DESTDIR="${pkgdir}" install
+}
+
+pkgver() {
+ cd "$srcdir/deadbeef-mpris2-plugin"
+ echo r$(git rev-list --count master).$(git rev-parse --short master)
+}