summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorToad King2020-12-25 22:03:55 -0600
committerToad King2020-12-26 20:40:07 -0600
commitf098785d9cda5b1d1e477bcbae54e6329cf95afd (patch)
treec73f697a60b0e16195d344697e41e5d4c36230a7
downloadaur-f098785d9cda5b1d1e477bcbae54e6329cf95afd.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb677281d6ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = deadbeef-pipewire-plugin-git
+ pkgdesc = Pipewire output plugin for the DeaDBeeF music player (devel branch)
+ pkgver = r23.3608435
+ pkgrel = 1
+ url = https://github.com/saivert/ddb_output_pw
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = meson
+ depends = pipewire
+ depends = deadbeef
+ source = git+https://github.com/saivert/ddb_output_pw.git
+ md5sums = SKIP
+
+pkgname = deadbeef-pipewire-plugin-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d05a49066b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/ddb_output_pw
+/pkg
+/src
+/*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a5180480b44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ToadKing <toadking at toadking dot com>
+pkgname=deadbeef-pipewire-plugin-git
+pkgver=r23.3608435
+pkgrel=1
+pkgdesc="Pipewire output plugin for the DeaDBeeF music player (devel branch)"
+arch=('i686' 'x86_64')
+url="https://github.com/saivert/ddb_output_pw"
+license=('GPL2')
+depends=('pipewire' 'deadbeef')
+makedepends=('git' 'meson')
+source=('git+https://github.com/saivert/ddb_output_pw.git')
+md5sums=('SKIP')
+
+build() {
+ arch-meson ddb_output_pw build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+
+pkgver() {
+ cd "$srcdir/ddb_output_pw"
+ echo r$(git rev-list --count main).$(git rev-parse --short main)
+}