summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgnat Loskutov2015-08-28 23:19:55 +0300
committerIgnat Loskutov2015-08-28 23:19:55 +0300
commit63b058a184883d20f5777bb12217e94576fd9d31 (patch)
tree3eb68293c3ff21c75c99b471c90711ec93eaf370
downloadaur-63b058a184883d20f5777bb12217e94576fd9d31.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9cd2e07991f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = deadbeef-plugin-infobar-ng-hg
+ pkgdesc = The Infobar-ng plugin for the DeaDBeeF audio player
+ pkgver = 180
+ pkgrel = 1
+ url = https://bitbucket.org/IgnatLoskutov/deadbeef-infobar-ng
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = mercurial
+ depends = deadbeef>=0.6,
+ depends = libxml2
+ source = hg+https://IgnatLoskutov@bitbucket.org/IgnatLoskutov/deadbeef-infobar-ng
+ md5sums = SKIP
+
+pkgname = deadbeef-plugin-infobar-ng-gtk2-hg
+
+pkgname = deadbeef-plugin-infobar-ng-gtk3-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebdadc1b25c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ignat Loskutov <ignat.loskutov@gmail.com>
+pkgbase='deadbeef-plugin-infobar-ng-hg'
+_hgname='deadbeef-infobar-ng'
+pkgname=('deadbeef-plugin-infobar-ng-gtk2-hg' 'deadbeef-plugin-infobar-ng-gtk3-hg')
+pkgver=180
+pkgrel=1
+pkgdesc="The Infobar-ng plugin for the DeaDBeeF audio player"
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/IgnatLoskutov/deadbeef-infobar-ng"
+license=(GPL2)
+depends=('deadbeef>=0.6', libxml2)
+makedepends=(mercurial)
+source=('hg+https://IgnatLoskutov@bitbucket.org/IgnatLoskutov/deadbeef-infobar-ng')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_hgname
+ hg id -n
+}
+
+build() {
+ cd $srcdir/$_hgname
+ make
+}
+
+package_deadbeef-plugin-infobar-ng-gtk2-hg() {
+ install -D -m644 $srcdir/$_hgname/gtk2/ddb_infobar_gtk2.so $pkgdir/usr/lib/deadbeef/ddb_infobar_gtk2.so
+}
+
+package_deadbeef-plugin-infobar-ng-gtk3-hg() {
+ install -D -m644 $srcdir/$_hgname/gtk3/ddb_infobar_gtk3.so $pkgdir/usr/lib/deadbeef/ddb_infobar_gtk3.so
+}