summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Uhl2020-10-18 18:58:22 +0200
committerPhilipp Uhl2020-10-18 18:58:22 +0200
commit827150bfb836d8e47c02858f7e44b4ccdc571a11 (patch)
tree6238855f6a7276ac0b3222d605e176d276942715
downloadaur-827150bfb836d8e47c02858f7e44b4ccdc571a11.tar.gz
Adds initial files
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ca53c177521
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = deadd-notification-center-git
+ pkgdesc = Customizable notification-daemon with notification center
+ pkgver = 1.7.3.r0.g2aacce2
+ pkgrel = 1
+ url = https://github.com/phuhl/linux_notification_center
+ arch = x86_64
+ license = BSD
+ makedepends = stack
+ makedepends = cairo
+ makedepends = pango
+ makedepends = gobject-introspection
+ depends = gobject-introspection-runtime
+ depends = gtk3
+ provides = deadd-notification-center
+ conflicts = deadd-notification-center-bin
+ conflicts = deadd-notification-center
+ source = git+https://github.com/phuhl/linux_notification_center.git#branch=master
+ md5sums = SKIP
+
+pkgname = deadd-notification-center-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b575eaffa6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Philipp Uhl <philipp.uhl@rwth-aachen.de>
+
+_gitname="linux_notification_center"
+pkgname=deadd-notification-center-git
+pkgver=1.7.3.r0.g2aacce2
+pkgrel=1
+pkgdesc="Customizable notification-daemon with notification center"
+url="https://github.com/phuhl/linux_notification_center"
+license=("BSD")
+arch=('x86_64')
+depends=('gobject-introspection-runtime' 'gtk3')
+makedepends=('stack' 'cairo' 'pango' 'gobject-introspection')
+provides=('deadd-notification-center')
+conflicts=('deadd-notification-center-bin' 'deadd-notification-center')
+source=("git+${url}.git#branch=master")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ make DESTDIR="$pkgdir" install
+}
+