summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2018-05-12 09:59:16 -0400
committerDavid Wells2018-05-12 10:03:19 -0400
commit1a474f5a722124bce9610ad1f9bd5209814db249 (patch)
treeff84cd1d549bcea06fc849bee3cd6b183b2a74e0
parentadc21ccd1a5c1307002b2b1723a33d6070c2b8ed (diff)
downloadaur-1a474f5a722124bce9610ad1f9bd5209814db249.tar.gz
Update to 9.0.
bzip2 is no longer a dependency, but several new optional dependencies exist.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 392c21217639..13514d909f0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deal-ii
pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
- pkgver = 8.5.1
- pkgrel = 0
+ pkgver = 9.0.0
+ pkgrel = 1
url = http://www.dealii.org/
install = deal-ii.install
arch = i686
@@ -10,25 +10,29 @@ pkgbase = deal-ii
makedepends = cmake
depends = boost
optdepends = arpack: Fortran77 subroutines designed to solve large scale eigenvalue problems
- optdepends = atlas-lapack: Complete LAPACK and BLAS implementation using optimized ATLAS routines
- optdepends = bzip2: A high-quality data compression program
+ optdepends = assimp: Library to import various well-known 3D model formats in an uniform manner
optdepends = p4est-deal-ii: The parallel forest (p4est) library, built to work with deal.II
optdepends = gsl: A modern numerical library for C and C++ programmers
+ optdepends = gmsh: An automatic 3D finite element mesh generator with pre and post-processing facilities
optdepends = hdf5-openmpi: General purpose library and file format for storing scientific data
optdepends = intel-tbb: High level abstract threading library
optdepends = lapack: Linear Algebra PACKage
optdepends = metis: partitioning graphs, finite element meshes, fill reducing orderings for sparse matrices.
optdepends = muparser: A fast math parser library
+ optdepends = nanoflann: a C++ header-only library for Nearest Neighbor (NN) search wih KD-trees
optdepends = netcdf-cxx-legacy: Legacy NetCDF C++ bindings
optdepends = openmpi: High performance message passing library (MPI)
optdepends = opencascade: Open CASCADE Technology, 3D modeling & numerical simulation
+ optdepends = parmetis: A parallel graph partitioning library
optdepends = petsc: Portable, extensible toolkit for scientific computation
+ optdepends = scalapack: subset of scalable LAPACK routines redesigned for distributed memory MIMD parallel computers
optdepends = slepc: Scalable library for Eigenvalue problem computations
+ optdepends = sundials: Suite of nonlinear differential/algebraic equation solvers
optdepends = trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems
optdepends = suitesparse: A collection of sparse matrix libraries
optdepends = zlib: Compression library implementing the deflate compression method found in gzip and PKZIP
- source = https://github.com/dealii/dealii/releases/download/v8.5.1/dealii-8.5.1.tar.gz
- sha1sums = fe8e4748c1d9650487fb5145429a58e8509de276
+ source = https://github.com/dealii/dealii/releases/download/v9.0.0/dealii-9.0.0.tar.gz
+ sha1sums = 1454485bd4ec4ad0252d87173e7fdbdf2ebb5d86
pkgname = deal-ii
diff --git a/PKGBUILD b/PKGBUILD
index e7ae74232746..c5085833387c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=deal-ii
_realname=dealii
-pkgver=8.5.1
-pkgrel=0
+pkgver=9.0.0
+pkgrel=1
pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
arch=("i686" "x86_64")
url="http://www.dealii.org/"
@@ -12,20 +12,24 @@ license=('LGPL')
depends=('boost')
optdepends=(
'arpack: Fortran77 subroutines designed to solve large scale eigenvalue problems'
- 'atlas-lapack: Complete LAPACK and BLAS implementation using optimized ATLAS routines'
- 'bzip2: A high-quality data compression program'
+ 'assimp: Library to import various well-known 3D model formats in an uniform manner'
'p4est-deal-ii: The parallel forest (p4est) library, built to work with deal.II'
'gsl: A modern numerical library for C and C++ programmers'
+ 'gmsh: An automatic 3D finite element mesh generator with pre and post-processing facilities'
'hdf5-openmpi: General purpose library and file format for storing scientific data'
'intel-tbb: High level abstract threading library'
'lapack: Linear Algebra PACKage'
'metis: partitioning graphs, finite element meshes, fill reducing orderings for sparse matrices.'
'muparser: A fast math parser library'
+ 'nanoflann: a C++ header-only library for Nearest Neighbor (NN) search wih KD-trees'
'netcdf-cxx-legacy: Legacy NetCDF C++ bindings'
'openmpi: High performance message passing library (MPI)'
'opencascade: Open CASCADE Technology, 3D modeling & numerical simulation'
+ 'parmetis: A parallel graph partitioning library'
'petsc: Portable, extensible toolkit for scientific computation'
+ 'scalapack: subset of scalable LAPACK routines redesigned for distributed memory MIMD parallel computers'
'slepc: Scalable library for Eigenvalue problem computations'
+ 'sundials: Suite of nonlinear differential/algebraic equation solvers'
'trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems'
'suitesparse: A collection of sparse matrix libraries'
'zlib: Compression library implementing the deflate compression method found in gzip and PKZIP'
@@ -33,7 +37,7 @@ optdepends=(
makedepends=('cmake')
install=deal-ii.install
source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
-sha1sums=('fe8e4748c1d9650487fb5145429a58e8509de276')
+sha1sums=('1454485bd4ec4ad0252d87173e7fdbdf2ebb5d86')
# where to install deal.II: change to something else (e.g., /opt/deal.II/)
# if desired.
@@ -86,9 +90,8 @@ build() {
fi
fi
- # Skip some warnings that appear if Trilinos uses OpenMP pragmas in headers
- # and also the new GCC7 warnings:
- extra_warning_flags=" -Wno-unknown-pragmas -Wno-implicit-fallthrough"
+ # Skip some warnings that appear if Trilinos uses OpenMP pragmas in headers:
+ extra_warning_flags=" -Wno-unknown-pragmas"
# the deal.II GCC flags are already well-chosen for speed (and O3 is known to
# be slightly slower than O2), so do not use flags in /etc/makepkg.conf by
@@ -100,7 +103,7 @@ build() {
-DDEAL_II_EXAMPLES_RELDIR=share/${pkgname}/examples/ \
-DDEAL_II_COMPONENT_DOCUMENTATION=OFF ../${_realname}-$pkgver
- # deal.II needs about 2 GB/compilation process so use fewer jobs if your
+ # deal.II needs about 3 GB/compilation process so use fewer jobs if your
# machine does not have the memory to support the maximum number.
make $MAKEFLAGS