summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Pintarelli2017-01-14 22:50:21 +0100
committerSimon Pintarelli2017-01-15 22:20:38 +0100
commitc8ab4590f601993c8b85893d1118647c58f44519 (patch)
treebd6de209205358068a8195a30cbc030e21a97276
parentec0062cbbfc18ed7e277eae380467f96003d719c (diff)
downloadaur-c8ab4590f601993c8b85893d1118647c58f44519.tar.gz
update to 12.8.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD75
2 files changed, 42 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e66a058100d..daed630338b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Apr 22 22:45:04 UTC 2016
pkgbase = trilinos
pkgdesc = An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems.
- pkgver = 12.6.2
+ pkgver = 12.8.1
pkgrel = 1
url = http://trilinos.org
arch = i686
@@ -22,9 +20,8 @@ pkgbase = trilinos
depends = openmpi
depends = python2
depends = boost
- conflicts = gtest
- source = http://trilinos.org/oldsite/download/files/trilinos-12.6.2-Source.tar.bz2
- md5sums = 4bcb91234399ada370be73d11e2df403
+ source = git+https://github.com/trilinos/Trilinos.git#tag=trilinos-release-12-8-1
+ md5sums = SKIP
pkgname = trilinos
diff --git a/PKGBUILD b/PKGBUILD
index 94e5fd488dcb..eeda4fa98bfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,68 @@
-# Maintainer: Myles English <myles at rockhead.biz>
+# vim:set ts=2 sw=2 et:
+# Maintainer: simon.pintarelli@gmail.com
# Contributor: Feng Wang <wanng.fenng@gmail.com>
pkgname=trilinos
-pkgver=12.6.2
+pkgver=12.8.1
pkgrel=1
pkgdesc="An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems."
arch=('i686' 'x86_64')
url="http://trilinos.org"
license=('LGPL3')
depends=('lapack' 'openmpi' 'python2' 'boost')
-conflicts=('gtest')
-source=(http://trilinos.org/oldsite/download/files/${pkgname}-${pkgver}-Source.tar.bz2)
+source=('git+https://github.com/trilinos/Trilinos.git#tag=trilinos-release-12-8-1')
+md5sums=('SKIP')
makedepends=('python2' 'python2-numpy' 'swig' 'gcc' 'gcc-fortran' 'openmpi' 'perl' 'blas' 'lapack' 'cmake')
-# gcc-fortran gcc-fortran-multilib
-md5sums=('4bcb91234399ada370be73d11e2df403')
+
build() {
- #export CFLAGS="$CFLAGS -g -O1"
- #export CXXFLAGS="$CXXFLAGS -g -O1"
- cd "$srcdir/$pkgname-$pkgver-Source"
+ cd "$srcdir/Trilinos"
- find ${srcdir}/${pkgname}-${pkgver}-Source -name "*" -type f -exec \
+ find ${srcdir}/Trilinos -path .git -prune -name "*" -type f -exec \
sed -i 's#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
- sed -i 's#SWIG_VERSION_CEILING 2.0.8#SWIG_VERSION_CEILING 3.0.2#' \
- ${srcdir}/${pkgname}-${pkgver}-Source/packages/PyTrilinos/CMakeLists.txt
+ sed -i 's#SWIG_VERSION_CEILING 2.0.8#SWIG_VERSION_CEILING 3.0.10#' \
+ ${srcdir}/Trilinos/packages/PyTrilinos/CMakeLists.txt
[[ -e build ]] && rm -rf build
- mkdir build
+ mkdir build
cd build
cmake .. \
- -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
- -DTrilinos_ENABLE_FEI=OFF \
- -DTrilinos_ENABLE_STKClassic=OFF \
- -DTrilinos_ENABLE_SEACAS=OFF \
- -DTrilinos_ENABLE_Sundance=OFF \
- -DTrilinos_ENABLE_TESTS=OFF \
- -DTrilinos_ENABLE_OpenMP:BOOL=ON \
- -DTPL_ENABLE_MPI:BOOL=ON \
- -DTrilinos_ENABLE_PyTrilinos:BOOL=ON \
- -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DTPL_ENABLE_Netcdf=OFF \
- -DTPL_ENABLE_QT=OFF \
- -DTPL_ENABLE_GLM=OFF \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- $EXTRA_ARGS
+ -DTrilinos_ENABLE_ALL_OPTIONAL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_INTREPID:BOOL=OFF \
+ -DTrilinos_ENABLE_SEACAS:BOOL=OFF \
+ -DTrilinos_ENABLE_Mesquite:BOOL=OFF \
+ -DTrilinos_ENABLE_FEI:BOOL=OFF \
+ -DTrilinos_ENABLE_Gtest:BOOL=OFF \
+ -DTrilinos_ENABLE_Shards:BOOL=OFF \
+ -DTrilinos_ENABLE_OpenMP:BOOL=OFF \
+ -DTpetra_INST_OpenMP:BOOL=ON \
+ -DTPL_ENABLE_gtest:BOOL=ON \
+ -DTPL_ENABLE_MPI:BOOL=ON \
+ -DTPL_ENABLE_Matio:BOOL=OFF \
+ -DTPL_ENABLE_GLM:BOOL=OFF \
+ -DTPL_ENABLE_NETCDF:BOOL=OFF \
+ -DTPL_ENABLE_X11:BOOL=OFF \
+ -DTrilinos_ENABLE_CXX11:BOOL=ON \
+ -DTrilinos_ENALBE_PAMGEN:BOOL=OFF \
+ -DTrilinos_ENABLE_PyTrilinos:BOOL=ON \
+ -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ $EXTRA_ARGS
make
}
package() {
- cd $srcdir/$pkgname-$pkgver-Source/build
+ cd $srcdir/Trilinos/build
make install DESTDIR=$pkgdir
- mkdir -p "${pkgdir}/etc/profile.d"
- echo "export TRILINOS_DIR=/usr" > "${pkgdir}/etc/profile.d/trilinos.sh"
- chmod +x "${pkgdir}/etc/profile.d/trilinos.sh"
-
- # header confilcts with openmpi
-# rm "${pkgdir}/usr/include/mpi.h"
+ # mkdir -p "${pkgdir}/etc/profile.d"
+ # echo "export TRILINOS_DIR=/usr" > "${pkgdir}/etc/profile.d/trilinos.sh"
+ # chmod +x "${pkgdir}/etc/profile.d/trilinos.sh"
}