summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2012-01-22 14:54:29 +0100
committerAntoine Lubineau2012-01-22 14:54:29 +0100
commit73eaced6bcc72c83858532843d8ff1b70bce90a0 (patch)
tree397423c2f86df72a242e6e735eec4677f68e7a20
downloadaur-73eaced6bcc72c83858532843d8ff1b70bce90a0.tar.gz
debhelper: adopted and upgraded
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD27
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7041f1283a56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = debhelper
+ pkgdesc = A collection of programs that can be used in a debian/rules file to automate common tasks
+ pkgver = 9.20120115
+ pkgrel = 1
+ url = http://kitenet.net/~joey/code/debhelper/
+ arch = any
+ license = GPL2
+ license = GPL3
+ makedepends = po4a>=0.24
+ makedepends = man-db>=2.5.1
+ makedepends = file>=3.23
+ depends = binutils
+ depends = dpkg>=1.14.15
+ depends = file>=3.23
+ depends = html2text
+ depends = man-db>=2.5.1
+ depends = perl>=5.6.0
+ depends = po-debconf
+ optdepends = dh-make
+ source = http://launchpad.net/debhelper/main/9.20120115/+download/debhelper_9.20120115.tar.gz
+ sha256sums = be935f693533fdd8c1f9bafd6b4bf746e4e9542a15a4f64d87a8cdd7a57524a4
+
+pkgname = debhelper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6534cb7beb50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+# Contributor: Andrei "Garoth" Thorp <garoth "at the nice" gmail "dot" com>
+
+pkgname=debhelper
+pkgver=9.20120115
+pkgrel=1
+pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
+arch=('any')
+url="http://kitenet.net/~joey/code/debhelper/"
+license=('GPL2' 'GPL3')
+depends=('binutils' 'dpkg>=1.14.15' 'file>=3.23' 'html2text' 'man-db>=2.5.1' 'perl>=5.6.0' 'po-debconf')
+makedepends=('po4a>=0.24' 'man-db>=2.5.1' 'file>=3.23')
+optdepends=('dh-make')
+source=("http://launchpad.net/debhelper/main/$pkgver/+download/debhelper_$pkgver.tar.gz")
+sha256sums=('be935f693533fdd8c1f9bafd6b4bf746e4e9542a15a4f64d87a8cdd7a57524a4')
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: