summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Lubineau2013-09-17 12:46:52 +0200
committerAntoine Lubineau2013-09-17 12:46:52 +0200
commitae5542132bfeb07a066181294e690016f15aa37c (patch)
treedbb6d50a8db782ad16ffd0e5b18f5e6b3c9753ec
parent68969a9e4a50c844f124d79be0b8956c34a5fc5c (diff)
downloadaur-ae5542132bfeb07a066181294e690016f15aa37c.tar.gz
debhelper: update and patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--fr.po.patch11
3 files changed, 29 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bce1c167423..94779bd22144 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = debhelper
pkgdesc = A collection of programs that can be used in a debian/rules file to automate common tasks
- pkgver = 9.20120909
+ pkgver = 9.20130720
pkgrel = 1
url = http://kitenet.net/~joey/code/debhelper/
arch = any
@@ -10,15 +10,17 @@ pkgbase = debhelper
makedepends = man-db>=2.5.1
makedepends = file>=3.23
depends = binutils
- depends = dpkg>=1.14.15
+ depends = dpkg>=1.16.2
depends = file>=3.23
depends = html2text
depends = man-db>=2.5.1
depends = perl>=5.6.0
depends = po-debconf
optdepends = dh-make
- source = http://launchpad.net/debhelper/main/9.20120909/+download/debhelper_9.20120909.tar.gz
- sha256sums = fabcdb9c41975ea0a1ccc66d6e065e424ed7a2119f6f1a6f7bfb7d06701370af
+ source = http://launchpad.net/debhelper/main/9.20130720/+download/debhelper_9.20130720.tar.gz
+ source = fr.po.patch
+ sha256sums = 4128575e19c2a6dbe8bfe2af591976b6bc737bb9b5d89e91492c6d72c487b01f
+ sha256sums = 66f5c36f2652876d5b0a11246ad5c0ca6bfb85fc9ca868068e1080837a45e8ad
pkgname = debhelper
diff --git a/PKGBUILD b/PKGBUILD
index f4f77411dc27..a48ff2c948b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
# Maintainer: Antoine Lubineau <antoine@lubignon.info>
+# Contributor: Charles Pigott <charlespigott@googlemail.com>
# Contributor: Andrei "Garoth" Thorp <garoth "at the nice" gmail "dot" com>
pkgname=debhelper
-pkgver=9.20120909
+pkgver=9.20130720
pkgrel=1
pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
arch=('any')
url="http://kitenet.net/~joey/code/debhelper/"
license=('GPL2' 'GPL3')
-depends=('binutils' 'dpkg>=1.14.15' 'file>=3.23' 'html2text' 'man-db>=2.5.1' 'perl>=5.6.0' 'po-debconf')
+depends=('binutils' 'dpkg>=1.16.2' 'file>=3.23' 'html2text' 'man-db>=2.5.1' 'perl>=5.6.0' 'po-debconf')
makedepends=('po4a>=0.24' 'man-db>=2.5.1' 'file>=3.23')
optdepends=('dh-make')
-source=("http://launchpad.net/debhelper/main/$pkgver/+download/debhelper_$pkgver.tar.gz")
-sha256sums=('fabcdb9c41975ea0a1ccc66d6e065e424ed7a2119f6f1a6f7bfb7d06701370af')
+source=("http://launchpad.net/debhelper/main/$pkgver/+download/debhelper_$pkgver.tar.gz"
+ 'fr.po.patch')
+sha256sums=('4128575e19c2a6dbe8bfe2af591976b6bc737bb9b5d89e91492c6d72c487b01f'
+ '66f5c36f2652876d5b0a11246ad5c0ca6bfb85fc9ca868068e1080837a45e8ad')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p1 < "$srcdir/fr.po.patch"
+}
build() {
cd "$srcdir/$pkgname"
diff --git a/fr.po.patch b/fr.po.patch
new file mode 100644
index 000000000000..aa6bd03b7f24
--- /dev/null
+++ b/fr.po.patch
@@ -0,0 +1,11 @@
+--- debhelper/man/po4a/po/fr.po 2012-09-11 01:53:27.000000000 +0900
++++ debhelper/man/po4a/po/fr.po.new 2013-06-22 12:53:18.042707445 +0900
+@@ -6022,7 +6022,7 @@
+ "répertoires à la recherche de fichiers portant un nom ressemblant à ceux "
+ "utilisés pour les pages de manuel. Nota : Seuls les vrais répertoires sont "
+ "scrutés, les liens symboliques sont ignorés. dh_installmanpages utilise "
+-"L<file(1) > pour vérifier si les fichiers sont dans un format correct, puis "
++"L<file(1)> pour vérifier si les fichiers sont dans un format correct, puis "
+ "se base sur l'extension du fichier pour l'installer dans le bon répertoire."
+
+ # type: textblock