summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2017-11-09 20:04:17 +0100
committerLuca Weiss2017-11-09 20:04:17 +0100
commit0eee3cfd60f55879c2a003ee991fa199bcd59b88 (patch)
tree8506e3c2deff00dddaac34b67e36b5bcc8dcda53
downloadaur-0eee3cfd60f55879c2a003ee991fa199bcd59b88.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..661e79afed48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = debhelper-sphinx
+ pkgdesc = debhelper scripts for sphinx docs: sphinxdoc.pm
+ pkgver = 1.6.5
+ pkgrel = 1
+ url = https://packages.debian.org/sid/all/sphinx-common
+ arch = any
+ license = BSD
+ source = http://ftp.de.debian.org/debian/pool/main/s/sphinx/sphinx-common_1.6.5-1_all.deb
+ sha512sums = 96b78e5ea8979afc3c14de1d4b739277019340b52d2f2f6e27b73df9bd5b0c2b3319887653e54c1a676a2235bee03cd60f46279b84b3775a865b570b98b6c7f2
+
+pkgname = debhelper-sphinx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5801a6877fb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+pkgname=debhelper-sphinx
+pkgver=1.6.5
+_debpkgrel=1
+pkgrel=1
+pkgdesc="debhelper scripts for sphinx docs: sphinxdoc.pm"
+arch=("any")
+url="https://packages.debian.org/sid/all/sphinx-common"
+license=('BSD')
+source=("http://ftp.de.debian.org/debian/pool/main/s/sphinx/sphinx-common_${pkgver}-${_debpkgrel}_all.deb")
+sha512sums=('96b78e5ea8979afc3c14de1d4b739277019340b52d2f2f6e27b73df9bd5b0c2b3319887653e54c1a676a2235bee03cd60f46279b84b3775a865b570b98b6c7f2')
+
+prepare() {
+ cd "$srcdir"
+ tar -xf data.tar.xz
+}
+
+package() {
+ install -Dm644 "$srcdir"/usr/share/perl5/Debian/Debhelper/Sequence/sphinxdoc.pm \
+ "$pkgdir"/usr/share/perl5/vendor_perl/Debian/Debhelper/Sequence/sphinxdoc.pm
+
+ install -Dm644 "$srcdir"/usr/share/doc/sphinx-common/copyright \
+ "$pkgdir"/usr/share/licenses/$pkgname/copyright
+}