summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hebb2013-08-22 23:23:57 -0400
committerThomas Hebb2013-08-22 23:25:22 -0400
commit08ba5ea0819db4c079651c431816a84c574f0196 (patch)
treedb1adae31fe6e5ccbf0a0a3bd8df64b65b2a51be
downloadaur-08ba5ea0819db4c079651c431816a84c574f0196.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46c6478dffba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = debian-whois-mkpasswd
+ pkgdesc = A features-rich front end to the password encryption function crypt(3).
+ pkgver = 5.0.26
+ pkgrel = 1
+ url = http://packages.debian.org/sid/whois
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://ftp.de.debian.org/debian/pool/main/w/whois/whois_5.0.26.tar.xz
+ sha256sums = 729625ef81425f4771e06492bb4f3e9f24bff75b8176044ce8d2f605f7ad6af5
+
+pkgname = debian-whois-mkpasswd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..543e9df55ccc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Thomas Hebb <tommmyhebb@gmail.com>
+pkgname=debian-whois-mkpasswd
+pkgver=5.0.26
+pkgrel=1
+pkgdesc="A features-rich front end to the password encryption function crypt(3)."
+arch=('i686' 'x86_64')
+url="http://packages.debian.org/sid/whois"
+license=('GPL')
+source=("http://ftp.de.debian.org/debian/pool/main/w/whois/whois_${pkgver}.tar.xz")
+sha256sums=('729625ef81425f4771e06492bb4f3e9f24bff75b8176044ce8d2f605f7ad6af5')
+
+build() {
+ cd "$srcdir/whois-$pkgver"
+ make mkpasswd
+}
+
+package() {
+ cd "$srcdir/whois-$pkgver"
+ make BASEDIR="$pkgdir/" install-mkpasswd
+}