summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2022-07-27 21:31:39 -0400
committerLukas Sabota2022-07-27 21:31:39 -0400
commitdb67e41e91b0b1753e35ac320219b1f91a04ede8 (patch)
tree6bd43369840914b640ab4370cf578e9bfb39fd7b
downloadaur-db67e41e91b0b1753e35ac320219b1f91a04ede8.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
-rw-r--r--arch-detect.patch32
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48618acc22e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = debootstrap-devuan-git
+ pkgdesc = Bootstrap a basic Debian-derived devuan system
+ pkgver = 1.0.126+nmu1devuan1.r0.gf8c417b
+ pkgrel = 1
+ url = https://git.devuan.org/devuan/debootstrap
+ arch = any
+ license = GPL
+ depends = perl
+ depends = wget
+ depends = binutils
+ optdepends = gnupg: check release signatures
+ optdepends = debian-archive-keyring: check release signatures for Debian
+ optdepends = debian-ports-archive-keyring: check release signatures for Debian Ports
+ optdepends = ubuntu-keyring: check release signatures for Ubuntu
+ conflicts = debootstrap
+ replaces = debootstrap
+ source = git+https://git.devuan.org/devuan/debootstrap.git
+ source = arch-detect.patch
+ sha256sums = SKIP
+ sha256sums = 2e37df02dbcdeeea3cc6dd440efaf28c9d03c45c357b6a170c3fa3b662e2b881
+
+pkgname = debootstrap-devuan-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96c19e51db10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: prg <prg-archlinux@xannode.com>
+# Maintainer: prg <prg-archlinux@xannode.com>
+
+# Based on existing debootstrap and debootstrap-git packages
+# Thank you to those contributors.
+
+pkgname=debootstrap-devuan-git
+pkgver=1.0.126+nmu1devuan1.r0.gf8c417b
+pkgrel=1
+pkgdesc="Bootstrap a basic Debian-derived devuan system"
+arch=('any')
+license=('GPL')
+url="https://git.devuan.org/devuan/debootstrap"
+conflicts=('debootstrap')
+replaces=('debootstrap')
+depends=('perl' 'wget' 'binutils')
+source=(git+https://git.devuan.org/devuan/debootstrap.git
+ arch-detect.patch)
+optdepends=('gnupg: check release signatures'
+ 'debian-archive-keyring: check release signatures for Debian'
+ 'debian-ports-archive-keyring: check release signatures for Debian Ports'
+ 'ubuntu-keyring: check release signatures for Ubuntu')
+sha256sums=('SKIP'
+ '2e37df02dbcdeeea3cc6dd440efaf28c9d03c45c357b6a170c3fa3b662e2b881')
+
+pkgver() {
+ cd debootstrap
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's|devuan/||'
+}
+
+prepare() {
+ cd debootstrap
+
+ sed -i 's/sbin/bin/g' Makefile
+
+ # Debian defaults
+ sed -i 's|export PATH|export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"|' debootstrap
+
+ # Detect Architecture
+ patch -p1 -i ../arch-detect.patch
+}
+
+package() {
+ cd debootstrap
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 debootstrap.8 "$pkgdir"/usr/share/man/man8/debootstrap.8
+}
diff --git a/arch-detect.patch b/arch-detect.patch
new file mode 100644
index 000000000000..600ff21570fa
--- /dev/null
+++ b/arch-detect.patch
@@ -0,0 +1,32 @@
+From b15594e90a8de4a9cd844bc80388e7b64fc4a51a Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@archlinux.org>
+Date: Fri, 16 Aug 2019 14:20:19 -0400
+Subject: [PATCH] add pacman capability to debootstrap architecture detection
+
+---
+ debootstrap | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/debootstrap b/debootstrap
+index 29c0443..f9d49a9 100755
+--- a/debootstrap
++++ b/debootstrap
+@@ -506,6 +506,15 @@ elif in_path udpkg && \
+ HOST_ARCH=$(/usr/bin/udpkg --print-architecture)
+ elif [ -e "$DEBOOTSTRAP_DIR/arch" ]; then
+ HOST_ARCH=$(cat "$DEBOOTSTRAP_DIR/arch")
++elif in_path pacman-conf; then
++ CARCH=$(pacman-conf Architecture)
++ case $CARCH in
++ i686) HOST_ARCH=i386 ;;
++ x86_64) HOST_ARCH=amd64 ;;
++ armv7h) HOST_ARCH=armhf ;;
++ aarch64) HOST_ARCH=arm64 ;;
++ *) echo "Unknown architecture: $CARCH" && exit 1
++ esac
+ fi
+ HOST_OS="$HOST_ARCH"
+ # basic host OS guessing for non-Debian systems
+--
+2.22.1
+