summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoritsme2018-07-11 11:11:34 +0800
committeritsme2018-07-11 11:11:34 +0800
commit95007240f677f2e1a466136afade39fd1980c467 (patch)
treec2b9f6a7a07b39045df1bea83dcf753924877155
parentc560a14f3a80d0682e272dca6371496335f6d75e (diff)
downloadaur-95007240f677f2e1a466136afade39fd1980c467.tar.gz
v0.7.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1be2602d57e2..109b06d2c1c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = debops
pkgdesc = A collection of Ansible playbooks, scalable from one container to an entire data center.
- pkgver = 0.6.0
+ pkgver = 0.7.2
pkgrel = 1
url = http://debops.org/
arch = any
license = GPL3
makedepends = python2-setuptools
- depends = python2
+ depends = python
depends = ansible
- depends = python2-netaddr
- depends = python2-ldap
- depends = python2-passlib
+ depends = python-netaddr
+ depends = python-ldap
+ depends = python-passlib
depends = util-linux
depends = encfs
depends = gnupg
+ depends = python-dnspython
conflicts = depops-git
- source = https://github.com/debops/debops-tools/archive/v0.6.0.tar.gz
- sha256sums = 285466d55b50cc628aaa7851e4b8a115307ffed709ce075236964b6db6c78a8f
+ source = https://github.com/debops/debops/archive/v0.7.2.tar.gz
+ sha256sums = 862e04cfeb6bdd6a30aea1cb063548784b14e1bd2750a8a61c4c1744ccab1b96
pkgname = debops
diff --git a/PKGBUILD b/PKGBUILD
index d507b9424f62..2b26368616d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
pkgname=debops
-pkgver=0.6.0
+pkgver=0.7.2
pkgrel=1
pkgdesc="A collection of Ansible playbooks, scalable from one container to an entire data center."
arch=('any')
url="http://debops.org/"
license=('GPL3')
-depends=('python2' 'ansible' 'python2-netaddr' 'python2-ldap' 'python2-passlib' 'util-linux' 'encfs' 'gnupg')
+depends=('python' 'ansible' 'python-netaddr' 'python-ldap' 'python-passlib' 'util-linux' 'encfs' 'gnupg' 'python-dnspython')
makedepends=('python2-setuptools')
conflicts=('depops-git')
-source=("https://github.com/$pkgname/debops-tools/archive/v$pkgver.tar.gz")
-sha256sums=('285466d55b50cc628aaa7851e4b8a115307ffed709ce075236964b6db6c78a8f')
+source=("https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('862e04cfeb6bdd6a30aea1cb063548784b14e1bd2750a8a61c4c1744ccab1b96')
build() {
- cd "$pkgname-tools-$pkgver"
+ cd "$pkgname-$pkgver"
python2 setup.py build
}
package() {
- cd "$pkgname-tools-$pkgver"
+ cd "$pkgname-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1
}