summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Mumford2018-05-23 16:11:07 +0100
committerStuart Mumford2018-05-23 16:11:07 +0100
commit2cd2f2501965a0c078b5139bcc4439daf41247ab (patch)
tree7ef75ec104b11d4d60003aa4a0df98032b80f60d
downloadaur-2cd2f2501965a0c078b5139bcc4439daf41247ab.tar.gz
v0.7.2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d141e8972b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = debops-git
+ pkgdesc = Your Debian-based data center in a box
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://github.com/debops/debops/
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ depends = ansible
+ depends = python-netaddr
+ depends = python-ldap
+ depends = python-passlib
+ depends = util-linux
+ depends = encfs
+ depends = gnupg
+ provides = debops
+ conflicts = debops
+ source = debops::git+https://github.com/debops/debops
+ sha256sums = SKIP
+
+pkgname = debops-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56d444b28e68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Build and install DebOps on the Arch Linux host
+#
+# Copyright (C) 2017 Maciej Delmanowski <drybjed@gmail.com>
+# Copyright (C) 2017 DebOps project https://debops.org/
+
+# To install DebOps on Arch Linux, after cloning the repository, run:
+#
+# makepkg -si
+#
+# This will install all of the required dependencies, then build and install
+# the DebOps Python package.
+#
+# After installation, run 'debops-update' to download or update the
+# role/playbook code from GitHub. The DebOps monorepo will be downloaded in
+# '~/.local/share/debops/debops/' directory on your user account.
+
+
+# Maintainer: Maciej Delmanowski <drybjed@gmail.com>
+pkgname=debops-git
+_pkgname=debops
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="Your Debian-based data center in a box"
+arch=('any')
+url="https://github.com/debops/debops/"
+license=('GPL3')
+depends=('python' 'ansible' 'python-netaddr' 'python-ldap' 'python-passlib' 'util-linux' 'encfs' 'gnupg')
+makedepends=('python-setuptools' 'git')
+provides=('debops')
+conflicts=('debops')
+source=("$_pkgname::git+https://github.com/debops/debops")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}