summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2021-04-19 09:18:26 +1000
committerMark Blakeney2021-04-19 09:18:26 +1000
commit247b8c72cb3492396471c2861c677ced26c06727 (patch)
tree46c2ec360d3c1760dedd3f51dfeaf83d913d5db4
downloadaur-247b8c72cb3492396471c2861c677ced26c06727.tar.gz
Initial version 1.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6c388687617
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = debugpy-run
+ pkgdesc = Finds and runs debugpy for VS Code "remote attach" command line debugging
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/bulletmark/debugpy-run
+ arch = any
+ license = GPL3
+ makedepends = python-pip
+ makedepends = python-wheel
+ depends = python>=3.6
+ source = debugpy-run-1.0.tar.gz::https://github.com/bulletmark/debugpy-run/archive/1.0.tar.gz
+ sha1sums = 01eb1bc5fd7ac43caac2d9eb3c33f4ecb86ab484
+
+pkgname = debugpy-run
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dd39bbd03b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar
+*.[gx]z
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19d1d1ca7b9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+pkgname=debugpy-run
+pkgver=1.0
+pkgrel=1
+pkgdesc='Finds and runs debugpy for VS Code "remote attach" command line debugging'
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python>=3.6")
+makedepends=("python-pip" "python-wheel")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha1sums=('01eb1bc5fd7ac43caac2d9eb3c33f4ecb86ab484')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --root="$pkgdir" \
+ --isolated \
+ --ignore-installed \
+ --no-deps \
+ --disable-pip-version-check \
+ --no-python-version-warning \
+ --no-warn-script-location \
+ --no-cache-dir \
+ --no-compile \
+ --progress-bar=off \
+ .
+
+ local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
+ local _pkgname="${pkgname//-/_}"
+ cd "$pkgdir/$pdir"
+ rm -f $_pkgname-*.dist-info/direct_url.json
+ sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
+ python -O -m compileall -q .
+}
+
+# vim:set ts=2 sw=2 et: