summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2023-11-05 09:09:17 +1000
committerMark Blakeney2023-11-05 09:09:17 +1000
commite61e1d816277588a74250600fe19a57d253a3bd8 (patch)
tree24c358e1caa699a4f6a228e35a1007d50db9da43
parent4def202cee497dd887b341bd5e32c22164e280fa (diff)
downloadaur-e61e1d816277588a74250600fe19a57d253a3bd8.tar.gz
Update to 1.7
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c14d9b8381f3..436c4fc042a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = debugpy-run
pkgdesc = Finds and runs debugpy for VS Code "remote attach" command line debugging
- pkgver = 1.6
+ pkgver = 1.7
pkgrel = 1
url = https://github.com/bulletmark/debugpy-run
arch = any
@@ -9,9 +9,10 @@ pkgbase = debugpy-run
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python>=3.6
depends = python-packaging
- source = debugpy-run-1.6.tar.gz::https://github.com/bulletmark/debugpy-run/archive/1.6.tar.gz
- sha1sums = 323f914e1dba629f2fa0431ce931d801dfa6a03c
+ source = debugpy-run-1.7.tar.gz::https://github.com/bulletmark/debugpy-run/archive/1.7.tar.gz
+ sha1sums = 5d63508bf16409a865ed3a434414fae0144323e6
pkgname = debugpy-run
diff --git a/PKGBUILD b/PKGBUILD
index 730b45af7b5b..4208a84bb2de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=debugpy-run
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc='Finds and runs debugpy for VS Code "remote attach" command line debugging'
url="https://github.com/bulletmark/$pkgname"
license=(GPL3)
arch=(any)
depends=("python>=3.6" "python-packaging")
-makedepends=(python-setuptools python-build python-installer python-wheel)
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('323f914e1dba629f2fa0431ce931d801dfa6a03c')
+sha1sums=('5d63508bf16409a865ed3a434414fae0144323e6')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {