summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke2022-06-15 20:14:52 -0500
committerLuke2022-06-15 20:14:52 -0500
commit4f04eb7fd0c108f49d525b4083c666b824951578 (patch)
treeac3c87221eefa2cb96fbaa0f335d4bb15118cb31
downloadaur-4f04eb7fd0c108f49d525b4083c666b824951578.tar.gz
v1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a848f8ecc6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = decay-factory
+ pkgdesc = A simple cli to convert any image to a Decay themed wallpaper
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/Infinitybeond1/nfetch-src
+ arch = x86_64
+ license = GPL3
+ makedepends = python-pip
+ depends = python3
+ depends = bash
+ source = conv.py::https://raw.githubusercontent.com/decaycs/decay-factory/main/conv.py
+ source = decay.sh::https://raw.githubusercontent.com/decaycs/decay-factory/main/decay.sh
+ source = req.txt::https://raw.githubusercontent.com/decaycs/decay-factory/main/requirements.txt
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = decay-factory
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f3d8cc69aae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luke <Infinitybeond1@protonmail.com>
+
+pkgname='decay-factory'
+pkgdesc="A simple cli to convert any image to a Decay themed wallpaper"
+pkgver=1.0
+pkgrel=0
+arch=('x86_64')
+url="https://github.com/Infinitybeond1/nfetch-src"
+license=('GPL3')
+source=("conv.py::https://raw.githubusercontent.com/decaycs/decay-factory/main/conv.py"
+ "decay.sh::https://raw.githubusercontent.com/decaycs/decay-factory/main/decay.sh"
+ "req.txt::https://raw.githubusercontent.com/decaycs/decay-factory/main/requirements.txt"
+ )
+makedepends=('python-pip')
+depends=('python3' 'bash')
+
+prepare() {
+ pip3 install -r req.txt
+}
+
+build() {
+ chmod 755 decay.sh
+ chmod 755 conv.py
+}
+
+package() {
+ install -D "conv.py" "$pkgdir/usr/bin/decayFactorypy"
+ install -D "decay.sh" "$pkgdir/usr/bin/decayFactory"
+}
+
+sha256sums=('SKIP' 'SKIP' 'SKIP')