summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-10-13 10:29:36 +0200
committerwillemw122015-10-13 10:29:36 +0200
commit9a27eaa3af60d3ed0f34da22f678a5cc20d3ae79 (patch)
treee870d3a3561865dbe254fdd2cfefd8b5c355bad7
downloadaur-9a27eaa3af60d3ed0f34da22f678a5cc20d3ae79.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD22
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdb1bf75ea3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v7
+# Tue Oct 13 08:29:05 UTC 2015
+pkgbase = decibel-audio-player
+ pkgdesc = GTK+ audio player
+ pkgver = 1.08
+ pkgrel = 4
+ url = http://decibel.silent-blade.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gstreamer0.10-python
+ depends = mutagen
+ depends = pygtk
+ depends = python2-dbus
+ depends = python2-notify
+ optdepends = python2-imaging: to display coverart
+ source = http://decibel.silent-blade.org/uploads/Main/decibel-audio-player-1.08.tar.gz
+ md5sums = e8ebaf819c198ff9951903e7c4056aef
+
+pkgname = decibel-audio-player
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d70a87f6f314
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Vladimir Chizhov <jagoterr@gmail.com>
+
+pkgname=decibel-audio-player
+pkgver=1.08
+pkgrel=4
+pkgdesc="GTK+ audio player"
+arch=('i686' 'x86_64')
+url="http://decibel.silent-blade.org/"
+license=('GPL3')
+depends=('gstreamer0.10-python' 'mutagen' 'pygtk' 'python2-dbus' 'python2-notify')
+#cddb-py
+optdepends=('python2-imaging: to display coverart')
+source=(http://decibel.silent-blade.org/uploads/Main/decibel-audio-player-$pkgver.tar.gz)
+md5sums=('e8ebaf819c198ff9951903e7c4056aef')
+
+package() {
+ cd $pkgname-$pkgver
+ make CONFIGURE_IN='sed -e "s|prefix|$(prefix)|g;s|^python|python2|"' \
+ prefix=/usr DESTDIR="$pkgdir/" install
+}
+