summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2020-11-23 10:18:38 +0100
committerJoan Bruguera2020-11-23 10:21:29 +0100
commit997a8f2f66de4edbbe3a527052a097c71d2040e0 (patch)
treed42d5d5685d382eeed14e092dc4214f4cc652dda
downloadaur-997a8f2f66de4edbbe3a527052a097c71d2040e0.tar.gz
Initial version - decK v1.2.3.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c8b3ddb5841
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = deck
+ pkgdesc = decK: Configuration management and drift detection for Kong and Kong Enterprise
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://github.com/Kong/deck
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ source = deck-1.2.3.tar.gz::https://github.com/Kong/deck/archive/v1.2.3.tar.gz
+ sha256sums = 7ee8428819a31f02d89db414c3dc7c3646ecb1dee2bda9838d88ad6e97de8632
+
+pkgname = deck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f952588e4265
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
+pkgname=deck
+pkgver=1.2.3
+pkgrel=1
+pkgdesc='decK: Configuration management and drift detection for Kong and Kong Enterprise'
+arch=('x86_64')
+url="https://github.com/Kong/$pkgname"
+license=('Apache')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Kong/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('7ee8428819a31f02d89db414c3dc7c3646ecb1dee2bda9838d88ad6e97de8632')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build ./...
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}