summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2021-01-06 17:03:33 +0100
committerJoan Bruguera2021-01-06 17:03:51 +0100
commit9e5949303b40e13dac7f34b26fe6294f06491b7c (patch)
tree282e501259c0f35392269815e5c4d64f99e91e0c
parente31766a667e0241c5b450c7e0e549535d4de88e1 (diff)
downloadaur-9e5949303b40e13dac7f34b26fe6294f06491b7c.tar.gz
Improvement: Warn about analytics collection.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rwxr-xr-xinstall.sh11
3 files changed, 15 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 794de3ff610c..ac61ab4b7422 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = deck
pkgdesc = decK: Configuration management and drift detection for Kong and Kong Enterprise
pkgver = 1.2.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Kong/deck
+ install = install.sh
arch = x86_64
license = Apache
makedepends = go
diff --git a/PKGBUILD b/PKGBUILD
index 0e89e4a747f6..5dc192226b7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname=deck
pkgver=1.2.3
-pkgrel=2
+pkgrel=3
pkgdesc='decK: Configuration management and drift detection for Kong and Kong Enterprise'
arch=('x86_64')
url="https://github.com/Kong/$pkgname"
@@ -9,6 +9,7 @@ license=('Apache')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Kong/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('7ee8428819a31f02d89db414c3dc7c3646ecb1dee2bda9838d88ad6e97de8632')
+install=install.sh
prepare(){
cd "$pkgname-$pkgver"
diff --git a/install.sh b/install.sh
new file mode 100755
index 000000000000..3794e709bd09
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,11 @@
+#!/usr/bin/env sh
+
+post_install() {
+ echo "! decK collects anonymized analytics by default"
+ echo "! It can be disabled by setting the environment variable DECK_ANALYTICS to off"
+ echo "! For more information, see https://docs.konghq.com/deck/commands/"
+}
+
+post_upgrade() {
+ post_install
+}