summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2021-05-21 23:44:59 +0200
committerJoan Bruguera2021-05-21 23:46:34 +0200
commita7da61ed498d035303e59da24f02ebdef0a573fb (patch)
tree00175356594fc0d00521478c634d24159e2ece71
parentd33ec60d7fe3fff6c8ba4a364f1b1ec0ec8bbd0f (diff)
downloadaur-a7da61ed498d035303e59da24f02ebdef0a573fb.tar.gz
decK v1.7.0.
Reenable analytics warnings (PR #379).
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
-rwxr-xr-xinstall.sh12
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18846681dc4a..68fcb5b65154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = deck
pkgdesc = decK: Configuration management and drift detection for Kong and Kong Enterprise
- pkgver = 1.6.0
+ pkgver = 1.7.0
pkgrel = 1
url = https://github.com/Kong/deck
+ install = install.sh
arch = x86_64
license = Apache
makedepends = go
- source = deck-1.6.0.tar.gz::https://github.com/Kong/deck/archive/v1.6.0.tar.gz
- sha256sums = 336aca1b9ff33e7303b34ffe8994cb92c2935318081104cf9bf563e760bb80fc
+ source = deck-1.7.0.tar.gz::https://github.com/Kong/deck/archive/v1.7.0.tar.gz
+ sha256sums = a1e73a36616775cfb81487da03fffd74d7a6e3ac5637a0c0dc0e691649170a85
pkgname = deck
diff --git a/PKGBUILD b/PKGBUILD
index 4372c4a64499..c50d6903b49b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname=deck
-pkgver=1.6.0
+pkgver=1.7.0
pkgrel=1
pkgdesc='decK: Configuration management and drift detection for Kong and Kong Enterprise'
arch=('x86_64')
@@ -8,7 +8,8 @@ url="https://github.com/Kong/$pkgname"
license=('Apache')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Kong/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('336aca1b9ff33e7303b34ffe8994cb92c2935318081104cf9bf563e760bb80fc')
+sha256sums=('a1e73a36616775cfb81487da03fffd74d7a6e3ac5637a0c0dc0e691649170a85')
+install=install.sh
prepare(){
cd "$pkgname-$pkgver"
diff --git a/install.sh b/install.sh
new file mode 100755
index 000000000000..ddb90781ece4
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,12 @@
+#!/usr/bin/env sh
+
+post_install() {
+ echo "! decK collects anonymized analytics by default"
+ echo "! It can be disabled by setting the environment variable DECK_ANALYTICS to off"
+ echo "! For more information, see https://docs.konghq.com/deck/commands/"
+ echo "! https://github.com/Kong/deck/issues/136"
+}
+
+post_upgrade() {
+ post_install
+}